X
Pritisnite ovdje da biste otišli na mobilnu verziju stranice.

Forum podrške

Firefox Mac: Most Youtube videos give "If Playback doesn’t begin shortly try restarting your device" error

Objavljeno

On Firefox (68.0.2) for Mac (OS 10.14.6): for the past month or so, most (but not all) Youtube videos give "If playback doesn’t begin shortly try restarting your device" error.

Videos play with no problem in my other browsers.

I have tried restarting in Safe Mode and the problem persists. Autoplayback is on. I also tried unchecking "Use hardware acceleration" in preferences, which had no effect (so I turned it back on). Clearing the cache has no effect.

Anyone have any thoughts?

On Firefox (68.0.2) for Mac (OS 10.14.6): for the past month or so, most (but not all) Youtube videos give "If playback doesn’t begin shortly try restarting your device" error. Videos play with no problem in my other browsers. I have tried restarting in Safe Mode and the problem persists. Autoplayback is on. I also tried unchecking "Use hardware acceleration" in preferences, which had no effect (so I turned it back on). Clearing the cache has no effect. Anyone have any thoughts?
Citiraj

Dodatni detalji o sistemu

Instalirani priključci

Facebook Container Freedom Library Extension

(also Adobe Acrobat disabled)

Aplikacija

  • Korisnički agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:68.0) Gecko/20100101 Firefox/68.0

Više informacija

Vlasnik pitanja

I should add that I rebooted my computer after each of the above except the cache clearing, of course.

I should add that I rebooted my computer after each of the above except the cache clearing, of course.
Je li vam ovo pomoglo?
Citiraj
Chris Ilias
  • Moderator
353 rješenja 1942 odgovora
Objavljeno

Hi kcatmull, What you're experiencing is not normal behaviour. I'm on the same version and OS as you, but Youtube videos work fine. First, let's try refreshing Firefox. This will purge a lot of your Firefox files, while retaining most of your personal data. For instructions, check out the following article: Refresh Firefox - reset add-ons and settings

Hi kcatmull, What you're experiencing is not normal behaviour. I'm on the same version and OS as you, but Youtube videos work fine. First, let's try refreshing Firefox. This will purge a lot of your Firefox files, while retaining most of your personal data. For instructions, check out the following article: [[Refresh Firefox - reset add-ons and settings]]
Je li vam ovo pomoglo?
Citiraj

Vlasnik pitanja

thank you! Tried that and it made no difference.

thank you! Tried that and it made no difference.
Je li vam ovo pomoglo?
Citiraj
jscher2000
  • Top 10 Contributor
8640 rješenja 70690 odgovora
Objavljeno

Hi kcatmull, YouTube has a diagnostic page showing which codecs your Firefox supports. Could you check and see whether you have mostly check marks (blue boxes) or also some red boxes:

https://www.youtube.com/html5

Hi kcatmull, YouTube has a diagnostic page showing which codecs your Firefox supports. Could you check and see whether you have mostly check marks (blue boxes) or also some red boxes: https://www.youtube.com/html5
Je li vam ovo pomoglo?
Citiraj

Vlasnik pitanja

I had no blue or red boxes, just the message below (ETA: thank you! I appreciate y'all helping):

I had no blue or red boxes, just the message below (ETA: thank you! I appreciate y'all helping):

Izmjenjeno od strane kcatmull

Je li vam ovo pomoglo?
Citiraj
jscher2000
  • Top 10 Contributor
8640 rješenja 70690 odgovora
Objavljeno

kcatmull said

I had no blue or red boxes, just the message below (ETA: thank you! I appreciate y'all helping):

Oh crap, that page was really useful before.

I dug up the old test code and reposted it here with some slight variations: https://www.jeffersonscher.com/sumo/html5-video.html

''kcatmull [[#answer-1246054|said]]'' <blockquote> I had no blue or red boxes, just the message below (ETA: thank you! I appreciate y'all helping): </blockquote> Oh crap, that page was really useful before. I dug up the old test code and reposted it here with some slight variations: https://www.jeffersonscher.com/sumo/html5-video.html
Je li vam ovo pomoglo?
Citiraj

Vlasnik pitanja

I got mostly "supported" and a couple of "probably"s -- see attached. Thanks again.

I got mostly "supported" and a couple of "probably"s -- see attached. Thanks again.
Je li vam ovo pomoglo?
Citiraj
jscher2000
  • Top 10 Contributor
8640 rješenja 70690 odgovora
Objavljeno

That's good! Unfortunately, I don't have any other leads.

When I search around, disabling hardware acceleration or updating graphics drivers seems to be the usual solution. I think your testing might have ruled those out.

Could you check for any error messages in Firefox's Web Console? You can open the Web Console in the lower part of the tab using either:

  • "3-bar" menu button > Web Developer > Web Console
  • (menu bar) Tools > Web Developer > Web Console
  • (Mac) Command+Alt+k

Then reload the page in the upper part of the tab and watch for error or security messages. Anything that sounds like it could be relevant?

That's good! Unfortunately, I don't have any other leads. When I search around, disabling hardware acceleration or updating graphics drivers seems to be the usual solution. I think your testing might have ruled those out. Could you check for any error messages in Firefox's Web Console? You can open the Web Console in the lower part of the tab using either: * "3-bar" menu button > Web Developer > Web Console * (menu bar) Tools > Web Developer > Web Console * (Mac) Command+Alt+k Then reload the page in the upper part of the tab and watch for error or security messages. Anything that sounds like it could be relevant?
Je li vam ovo pomoglo?
Citiraj

Vlasnik pitanja

I really appreciate your trying, anyway. Here's the results from the Web Console (PS DON'T JUDGE ME I was arguing with someone about the lyrics to All Star)

I really appreciate your trying, anyway. Here's the results from the Web Console (PS DON'T JUDGE ME I was arguing with someone about the lyrics to All Star)
Je li vam ovo pomoglo?
Citiraj
jscher2000
  • Top 10 Contributor
8640 rješenja 70690 odgovora
Objavljeno

Hi kcatmull, those message don't sound like fatal errors, so... I'm baffled.

One other thing you could look at in the Dev Tools panel is the Network section. It lists the files Firefox is trying to retrieve and what happened with the request. You can expect to see a lot of entries for each page, but there's a filtering button above the list to show only media files which might help with that. Some of these files loaded before I clicked the play button, and the rest loaded after that.

Hi kcatmull, those message don't sound like fatal errors, so... I'm baffled. One other thing you could look at in the Dev Tools panel is the Network section. It lists the files Firefox is trying to retrieve and what happened with the request. You can expect to see a lot of entries for each page, but there's a filtering button above the list to show only media files which might help with that. Some of these files loaded before I clicked the play button, and the rest loaded after that.
Je li vam ovo pomoglo?
Citiraj

Vlasnik pitanja

I don't think this is much different from yours but I put it here in case it tells you anything. Thanks so much for your help--I know you've gone way out of your way. Maybe someone will come by whose wrangled this successfully at some point.

I don't think this is much different from yours but I put it here in case it tells you anything. Thanks so much for your help--I know you've gone way out of your way. Maybe someone will come by whose wrangled this successfully at some point.
Je li vam ovo pomoglo?
Citiraj
jscher2000
  • Top 10 Contributor
8640 rješenja 70690 odgovora
Objavljeno

Korisan odgovor

Could you try disabling support for WebM video? Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste webm and pause while the list is filtered

(3) Double-click the media.webm.enabled preference to switch the value from true to false

Any difference when testing YouTube?

Could you try disabling support for WebM video? Here's how: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''webm''' and pause while the list is filtered (3) Double-click the '''media.webm.enabled''' preference to switch the value from true to false Any difference when testing YouTube?
Je li vam ovo pomoglo? 1
Citiraj

Vlasnik pitanja

AAHHHHHHH THAT WORKED! thank you so much! Quick check just so I know -- what will now be missing from media playback for me?

AAHHHHHHH THAT WORKED! thank you so much! Quick check just so I know -- what will now be missing from media playback for me?
Je li vam ovo pomoglo?
Citiraj
jscher2000
  • Top 10 Contributor
8640 rješenja 70690 odgovora
Objavljeno

Okay, that tells us your Firefox has trouble with WebM media, but not why it has trouble.

WebM was invented by Google and I don't know if other sites use it. Most seem to use MP4, so I don't think you'll have too much trouble unless you want to play high frame rate (60fps) video on YouTube (might only be available in WebM).

Okay, that tells us your Firefox has trouble with WebM media, but not why it has trouble. WebM was invented by Google and I don't know if other sites use it. Most seem to use MP4, so I don't think you'll have too much trouble unless you want to play high frame rate (60fps) video on YouTube (might only be available in WebM).
Je li vam ovo pomoglo?
Citiraj

Vlasnik pitanja

yes I've been poking around and nothing (Twitter/Facebook videos, gifs etc) seems broken. I'm so grateful -- thank you!

yes I've been poking around and nothing (Twitter/Facebook videos, gifs etc) seems broken. I'm so grateful -- thank you!
Je li vam ovo pomoglo?
Citiraj
Postavite pitanje

Morate se prijaviti na račun da biste odgovarali na poruke. Molimo postavite novo pitanje, ako još uvijek nemate račun.