Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How keep tabs open after quitting Firefox.

  • 4 odgovori
  • 2 ima ovaj problem
  • 4432 views
  • Posljednji odgovor poslao ritamontague

more options

Every time I quit Firefox it closes all my tabs. I have "restore previous session" checked in the preferences. Is there something else I can do besides making pinned tabs? I just want my normal tabs to open when I reboot Firefox. Thanks.

Izabrano rješenje

Thank you for the update. That particular setting shouldn't prevent restoring tabs -- I use that setting -- but maybe changing that setting changed something else at the same time. ??

As a backup to the built-in feature, you could consider a session management extension. These are the ones I'm aware of that you might investigate/try out:

Use database storage:

Use bookmark storage:

Pročitajte ovaj odgovor sa objašnjenjem 👍 0

All Replies (4)

more options

Hi ritamontague, do you use "Quit" to exit out of Firefox, either:

  • "3-bar" menu button > Quit
  • (menu bar) Firefox > Quit

If you use the X button, then Firefox would treat that window as a closed window and you would need to use one of the following to get it open again:

  • "3-bar" menu button > Library > History > Recently Closed Windows
  • Library toolbar button > History > Recently Closed Windows
  • (menu bar) History > Recently Closed Windows

If Firefox doesn't remember either open or closed windows at your next startup, there could be a problem with settings.

Session history is considered part of browsing history, so it is important that not be cleared. More details if needed.

more options

Thank you for responding. I quit Firefox via the Firefox tab. I looked and saw that I had "Delete Cookies and site data when Firefox is closed" checked. I unchecked it and was able to keep my tabs. It's unfortunate, because I would like to delete cookies but keep my tabs. I have a Mac so the three line menu bar doesn't show up. Anyway, I fixed it the best I could. Thanks again.

more options

Odabrano rješenje

Thank you for the update. That particular setting shouldn't prevent restoring tabs -- I use that setting -- but maybe changing that setting changed something else at the same time. ??

As a backup to the built-in feature, you could consider a session management extension. These are the ones I'm aware of that you might investigate/try out:

Use database storage:

Use bookmark storage:

more options

Thank you. I will keep those in mind. It's weird that it worked even when it shouldn't have, but I am happy about it.