Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot load inbox in live.com

  • 2 odgovori
  • 1 ima ovaj problem
  • 10 views
  • Posljednji odgovor poslao elsb

more options

Last week, live.com upgraded their email program. https://outlook.live.com/mail/inbox Before that, I could load my inbox. Now it just says "LOADING" in the center of the screen. I know it's the Firefox browser that is the issue because live.com inbox will load in Chrome. I already cleared cache and cookies in Forefox. I do not wish to re-install and lose all my stuff (ie bookmarks etc). Has anyone else had this issue since last week, and come up with a solution?

Thanks

All Replies (2)

more options

I frequently use Outlook for email. The email address that I use for Mozilla is through Outlook. I have no issues with the new inbox. There were some minor glitches when it was in the beta, but now that it has been rolled out to all users, it seems to be working fine.

Where I believe that you may be running into issues is that you are running Firefox 40, which is severely outdated. This is because you are running Windows XP, an operating system that is no longer supported by Firefox. This means that you will be able to install up to Firefox version 52, but that's it.

Running an outdated browser can cause various security, performance and functional issues. This is the likely reason why you are having issues opening the Outlook website on your browser.

more options

Thanks for your opinion. The inbox loaded fine until live.com updated last week, as mentioned above. And it loads in Chrome, so Microsoft said Firefox is the issue and I should try and troubleshoot with Firefox.

I manage a community continuing ed program, and it runs solely on Outlook Express. So changing OS and email clients means finding something comparable. I have looked for years and found nothing that is going to work. Tried Thunderbird too. Not a good fit.