Search Support

PDF files are blank when opened in Firefox

  • 5 odgovori
  • 1 ima ovaj problem
  • 6078 views
  • Posljednji odgovor poslao kaylaartist

more options

I have been using Firefox as my default application to open PDF files and everything worked correctly until recently. Now when I open a PDF, the file opens a blank browser tab and continues to open more blank tabs until I close Firefox to stop more tabs from opening.

I have restarted Firefox in safe mode and get the same results.

What can I do to fix this?

Windows 10 x64

Izabrano rješenje

hi, i think this problem can arise if you set firefox to be the default pdf-viewing app in your windows settings AND have chosen to open pdfs with the system's default app in the firefox settings - you'll then end up with this endless loop.

in order to resolve this, go to the firefox menu ≡ > options > general panel and in the applications panel set the default action for portable document format (pdf) to preview in firefox.

Pročitajte ovaj odgovor sa objašnjenjem 👍 0

All Replies (5)

more options

Try Firefox Safe Mode to TEST & see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

Thanks for the answer, but I mentioned in my original post that the issue continues in safe mode.

Other suggestions?

more options

Odabrano rješenje

hi, i think this problem can arise if you set firefox to be the default pdf-viewing app in your windows settings AND have chosen to open pdfs with the system's default app in the firefox settings - you'll then end up with this endless loop.

in order to resolve this, go to the firefox menu ≡ > options > general panel and in the applications panel set the default action for portable document format (pdf) to preview in firefox.

more options

@philipp - That worked! Thanks very much for your help!

Just for the sake of documentation - if a user sets Firefox to be their default PDF viewing app in Windows, Firefox needs to be set to "Preview in Firefox" NOT "Use Firefox (default)". The "Use Firefox (default)" option results in an endless loop of Firefox attempting to open the PDF in new tabs.

more options

No. None of this helps. New ff 63 has no option to preview in firefox. and no matter from where I open a pdf, I will always get a blank web page in ADDITION TO the pdf file! I have continuously had this issue. Get it resolved after much back and forth with ff, then they update, and it is back. Now, I also cannot use Google for search option from thunderbird. At this point, despite ff being, or having been the best browser, I am currently disgusted with them. They refuse to accept that this is a bug