Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox is now hanging on opening some links that open right up in Chrome

  • 1 odgovor
  • 1 ima ovaj problem
  • Posljednji odgovor poslao Shadow110

more options
Several links recently will not open in FF. Sometimes I can solve this by turning off my VPN. Both of the following links will not open at all with the VPN off, but open right away in Chrome: email link for - direct Counterpunch link -

All Replies (1)

more options

Hi well you have nailed some issues that are related to your VPN. That's something that is between you and your VPN. No information was supplied at time of question as to that being a dedicated or a Firefox Extension or any other Extension.

Try Firefox Safe Mode to TEST & see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".


If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

Is there a Shield next to the Padlock ? One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection

What Security Program are you using ? You do not mention any error messages but : There is security software like Avast/AVG, Kaspersky, BitDefender and ESET that intercept secure connections and send their own certificate. If you are running any of the above software please check their community forum for a work around to apply settings.

These pages are also for the errors you may have besides relating to the above.

There is other things if the above does not help.