Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How can I PERMANENTLY disable backspace "function"?

  • 11 odgovori
  • 7 ima ovaj problem
  • 955 views
  • Posljednji odgovor poslao MyDavid

more options

The problem of changing web pages while correcting typing using the backspace key can be fixed with about:config as shown in other items. But, is there a way to permanently disable the backspace key in navigation or do I have to go through this every time there is a Firefox update?

Izabrano rješenje

You can use the user.js file in the profile folder to initialize this pref on every start of Firefox to 2.

  • user_pref("browser.backspace_action", 2);

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Pročitajte ovaj odgovor sa objašnjenjem 👍 1

All Replies (11)

more options

Got me confused. Is the Keyboard Backspace or the Browser Back Button.

If it is the browser Back Button then can open Customize and remove it.

There was away to disable the Backspace Key. https://www.google.ca/search?q=firefox+disable+back+space+key&ie=utf-8&oe=utf-8&client=firefox-b&gfe_rd=cr&dcr=0&ei=pqE1Wv2gLsaFiAPzgpKQBQ

Check to see if any of these still work.

Since 57+ things that used to work , no longer work. Info will get out, just not around when you need it.

Please let us know if this solved your issue or if need further assistance.

more options

You can set browser.backspace_action to 2 on the about:config page. See:

(0:B/F; 1:Scroll; 2:No)

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

more options

Yes, I know about the about:config option and have used it. My question is how can I make it permanent? The last Firefox update reset the flag to 0 and back to the 'bad behavior'. Or do I have to go back and fix Firefox everytime there is an update?

more options

Odabrano rješenje

You can use the user.js file in the profile folder to initialize this pref on every start of Firefox to 2.

  • user_pref("browser.backspace_action", 2);

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

more options

Thanks, The user.js file was what I needed.

more options

It is INCORRECT what got posted above: those suggestions do NOT resolve this newest firefox issue, not in my case.

1) Forcing no-geek users to make changes in about:config for things that should and would never require a change had sw developers half an ounce of common sense before rolling out a "new feature", that frankly is ridiculous.

2) Even worse: suggesting to go down to javascript files and make a change there.

3) Even worse, when the suggested change does not even WORK.

Thus 4) Programmers: Give back what belongs to the backspace character: the functionality to delete the prior characters!!

5) To me, this issue only surfaced with the recent firefox "update". Note: An "update" must never make any usage WORSE, because then it is FAILURE, not an update!

6) All the more problematic: Users first think "huh, what's wrong?? Application A suddenly behaves wrong!" Checks application B, and C, and D - no change. Finally realizes: "It's caused by Firefox!!"

What a time waste.

P.S.: Firefox Developer edition does NOT have this error (yet).

more options

Hi MyDavid

What "new feature" are you talking about?

This 'feature' has been present in Firefox probably from the very first release(s), so it is not at all a new feature. You can set via a pref on the about:config page what action you want the Backspace key to perform and change it if you do not like the default action.

// Backspace and Shift+Backspace behavior
// 0 goes Back/Forward
// 1 act like PgUp/PgDown
// 2 and other values, nothing

If you have a problem with the backspace key then likely something else is interfering.

You can check that in Safe Mode.

more options

Then you must be considered very special by firefox programmers, such that extra for you they made an exception "from the very first release" onwards.

Because for others, including myself, ALL releases of firefox since its inception have had the backspace button do its historically assigned function: delete prior characters.

Only just now, and I can (yet) only speak for wordpress admin pages (haven't tried anything else yet), only just now this idiocracy started, to have the backspace character DELETE ALL EDITED ARTICLE IN WORDPRESS because the it sends you to the prior page. And without so much of a warning!

If you've ever written more than speech bubbles in a paint-by-the-numbers kids' book then you will feel the PAIN upon such experience with firefox when some other user reports it. Here, myself reporting it.

I still believe that "it can't be true", hoping it's just some unlucky and temporary constellation of the stars shining on both wordpress and firefox (read, a bug between the two), that led to this annoyance.

Because, as said, Firefoxis developer edition does NOT (yet) have it. There, as in Chrome, the backspace character still is the backspace character. Hence why, sadly, my hope seems unjustified: this makes it unlikely that it's a temporary glitch between firefox and wordpress. Had Chrome shown the same sudden issue, I'd have assigned the bug to wordpress without hesitation. And had it shown in my other software, I'd had assigned it to my laptop, not firefox. But: The issue exists ONLY with firefox. And JUST NOW.

more options

Oh, and did you read my post at all? "You can set via a pref on the about:config page what action you want the Backspace key to perform and change it if you do not like the default action.

// Backspace and Shift+Backspace behavior // 0 goes Back/Forward // 1 act like PgUp/PgDown // 2 and other values, nothing"

I clearly wrote "This does NOT work".

Again, maybe YOU are lucky. Enjoy it then.

more options

Like I wrote above, if the backspace button isn't working like it should when an input area has focus then something is wrong. I've never had a problem with the backspace behaving weirdly with the above mentioned pref set to 2, but I'm on Linux and there is 2 the default value.

Does it really happen that you activate the tab back history if you press the backspace key in an input area like "Post a reply" used on this forum?

more options

No it does not happen here, I can delete the s.it I wrote earlier ;-) But as explained it happens with wordpress admin area edit screens. And ONLY with this edition "Quantum 59.0.2", NOT with "Developer Edition", NOT with Chrome (can't speak for IE, don't use crap, sorry). And it did NOT happen until the (now) penultimate firefox update. Maybe a glitch... hopefully one of the next updates will bring back to me too what users consider the norm: backspace deletes prior characters, delete key deletes next characters. Simple. I am amazed by your perseverance to help, thank you! I can't use linux though. In this case, sorry to admit, I do use crap, yes: Windows. Either way, pl don't waste your time, I will just use one of the other two browsers mentioned, until I notice this one is normal again. To be frank, I don't know the difference between my two firefoxies anyway, BOTH let me use developer tools, just one has white background, the other black, lol. :) I am sure I am just one of miilions of users puzzled by the same. Thanks again!