Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

when I try to open a link blank tabs start opening and I have to shut down my browser

  • 3 odgovori
  • 1 ima ovaj problem
  • 2 views
  • Posljednji odgovor poslao cor-el

more options

I download a pdf and when I go to open it blank tabs start opening and don't stop so I am forced to shut down my browser or when I click on Firefox to open it it will just keep opening until I am forced to shut down my browser. Help I have classes and have no time for this BS. Please and Thank you

All Replies (3)

more options

Deleting mimeTypes.rdf will reset all download actions to the default settings. In Firefox 55, there is a new file named handlers.json

Type about:support<enter> in the address bar.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the above file. Then rename or delete it. Restart Firefox.

more options

When you open a PDF using either the completed downloads list or going out to the folder where you saved it, it should be opened in the default program designated in Windows. If that has become set to Firefox, but Firefox doesn't want it, you can get this problem of back and forth.

Can you try to reassign PDFs to your stand-alone PDF reader program? https://support.microsoft.com/en-us/help/4028161/windows-change-default-programs-in-windows-10

Alternately, you can set Firefox to view PDFs in the built-in viewer. However, it's slower than using a program specialized in handling PDFs so that's not the best solution. If you want to try it anyway, see: View PDF files in Firefox or choose another viewer.

more options

Note that you should never select Firefox as the application to handle a file if you get an open with or save dialog. Firefox wouldn't ask if it was able to handle this file and selecting Firefox and especially checking the "automatically" setting will cause endless tabs opening.