Search Support

How do I get back inline image display in email?

  • 23 odgovori
  • 10 ima ovaj problem
  • 9952 views
  • Posljednji odgovor poslao golfwizard

more options

I searched and checked all settings and I am still not seeing inline images for mail that I was seeing them for, before, like Facebook.

I fixed it by rebooting Windows 10, but I do not want to reboot Win10 that often. I do not have a VIEW command as I saw someone mention.

I am using Thunderbird 52.2.1

thanks, heartdaughter

Izabrano rješenje

My computer was in the shop since 8/25/17. The problem is fixed and I assume because Kaspersky updated itself.

Thanks to everyone who helped.

heartdaughter

Pročitajte ovaj odgovor sa objašnjenjem 👍 0

All Replies (20)

more options

It seems to me that the lack of the "View command" is the real problem.

Use F10 or alt+v to make a menu appear and in that menu go to View|Toolbars and tick the checkboxes. Now you have a menu with a View option, you can use it to display attachments inline, and also to view messages in "original html".

more options

Zenos, you are right, I found the view menu option, and I did not see it at first and I already had it set to view in html. This does NOT solve my problem but might help someone else.

more options

I have new information:

This time After I restarted Windows 10 it did NOT fix the problem.

Also my anti virus program does not handle the email at all. I use Kaspersky.

Thank you people.

more options

Maybe this reply will bump up this question so that more people will see it. I really want to be able to see images in my emails again.

more options

re :I found the view menu option, and I did not see it at first and I already had it set to view in html.

There are different ways of seeing images and it depends upon how that image was sent.

If images that are sent as attachments: these can be viewed 'inline' by selecting: 'View' > select 'display attachments inline'

However, you mention 'facebook' which makes me wonder if you are talking about 'Remote Content'. Confirm these emails are not in the 'junk' / 'spam' folder. They will not allow remote content in anything in those folders.

After selecting email so it opens in lower Message Pane, do you see a message just below the headers which says 'To protect your privacy, Thunderbird has blocked remote content in this message'  ? It should display an 'Options' button which allows you switch to allowing remote content in that email.

more options

Greetings Toad-Hall and thanks for the reply. These are not attachments. I am referring to remote content. They are not in spam/junk, but in my inbox folder. There is no message about Thunderbird blocking. I read that help page and it does not help.

I was able to view these images all along, for years. This problem is recent. I have upgraded to Windows 10 whereas I was using Windows 7 before.

Also, I looked in the list of remote images allowed and it is full of the people from whom I get messages and they are all set to ALLOW, which means I got the option in the past and set it to allow.

I do suspect Windows 10, but I cannot think of any setting in Windows that would block Thunderbird from downloading remote images.

Thanks, heartdaughter I will include an image as sample of what I get.

more options

I have managed to replicate a similar situation where the 'To protect your privacy, Thunderbird has blocked remote content in this message'  ? is missing.

If 'Simple HTML' is selected then the remote content message with options button is missing. Please check: 'View' > 'Message Body As' > 'select 'Original HTML'.

more options

Yes I have Original HTML checked.

I also saw someone said to check in config

Browse to Tools -> Options -> Advanced tab -> Config Editor

   Search for mail.default_html_action and make sure it is set to 3 (allow original HTML).

Mine was set to 0 and I changed it to 3 but it still did not help.

heartdaughter

more options

I just uninstalled and reinstalled Thunderbird and it did not help.

heartdaughter

more options

heartdaughter said

Yes I have Original HTML checked. I also saw someone said to check in config Browse to Tools -> Options -> Advanced tab -> Config Editor Search for mail.default_html_action and make sure it is set to 3 (allow original HTML). Mine was set to 0 and I changed it to 3 but it still did not help. heartdaughter

On further research this setting is about sending email and here are the options:

What should it do when sending a HTML message to somebody who might not be able to view it. See Plain text 0: Ask 1: Send as plain text 2 (default): Send as HTML anyways 3: Include both plain text and HTML message bodies in message

Clarification. heartdaughter

more options

I found another setting that seems to be set correctly but might affect seeing images in emails.

mailnews.display.html_as

How to display HTML parts of a message body [29]

0 (default): Display the HTML normally 1: Convert it to text and then back again 2: Display the HTML source 3: Sanitize the HTML

Also, I cannot find information on the following three tags.

mailnews.display.html_sanitizer.allowed_tags.migrated;true mailnews.display.html_sanitizer.drop_media;false mailnews.display.html_sanitizer.drop_non_css_presentation;true

Could any of these be the source of my problem?

heartdaughter

more options

Try this:

  1. Open your profile folder by going to Help > Troubleshooting Information and clicking Open Folder.
  2. Close Thunderbird.
  3. Browse to the subfolder containing your Inbox messages. For IMAP, that would be ImapMail\<name_of_imap_server>. For POP, that would be Mail\<name_of_pop_server>.
  4. Delete (or move) the Inbox.msf file.
  5. Start Thunderbird.

Note: if you have set some message flags, such as for watching a thread, you may lose that info.

more options

Tonnes, thank you for the suggestion. I tried it, but it did not help. I still do not see images in email messages. Should I put back the inbox.msf file? The new one is zero bytes.

heartdaughter

more options

Are you sure you (re)moved the proper file for the proper account (with a recent timestamp probably)? Also: did Thunderbird start re-indexing when selecting the affected Inbox?

If you moved the proper file (since you may have more Inbox and Inbox.msf files for several accounts / Inboxes), I would expect the indexing process to start as soon as you select the Inbox after starting Thunderbird, as well as the new Inbox.msf file to be larger than 0 bytes as a result when there is at least one message in the Inbox. If not, you may have removed another Inbox.msf file. You would find out when selecting any other Inbox in Thunderbird now if it is still available - the folder chosen in the file explorer could even be an outdated folder for a no longer valid account, or for a changed server name.

It may be too soon to move the file back, unless the associated Inbox file has the same older timestamp in case no new mail is retrieved, but it may be best not to and I would not risk it. When new mail was retrieved after removing the file (even if reindexing had taken place and the new file would be larger than 0 bytes, i.e. if you overwrite the new .msf file now), there will be a mismatch. Index files will just be rebuilt automatically - the only drawbacks are losing such flag info if any, and a little time to rebuild which can be a number of minutes if the Inbox’s content is large.

Come to think of it: you could also try right-clicking the affected Inbox, choosing Properties and clicking Repair folder, which would rebuild the .msf file, but I forgot if that fixed the image issue for me when I had it. I think it did not, as repairing isn’t similar to removing.

Nevertheless, I would not do so yet and first make sure the previous steps were performed on the right folder. When in doubt, a search for the most recent Inbox file based on timestamps would help, or just removing any .msf file in the profile’s subtrees, but it’s best to stick with the proper folder only.

Can you recall what happened to make the images not display? They never did, or did you block them in some way? If they never did, there may be an issue related to http and https content. That could be tested by sending an email to yourself with links for images residing on an http and an https URL.

more options

Thanks Tonnes, I did it right. It rebuilt itself.

I had the images working and then they stopped. I tried to send an email to myself but it just showed the links.

The only change I made was to start using Windows 10, but I could see them under windows 10 and then they stopped showing.

Something is blocked them, but I do not know what.

thanks for you help, heartdaughter

more options

The links will display as links allright - you should test with an email containing inserted images that are located on a remote URL.

The issue reminds me of this question that eventually got no clear solution, but it was certificate and https related. Could you read that and see if it is of any help?

You could quickly try disabling any firewall/security software to see if that helps. Given that you wrote they did work earlier, I would create another profile as a test and set up the account there to see what happens. That would indicate the issue is in your Thunderbird profile and not caused by security software or another reason.

You could also try the code given for the Error Console and test, but be sure to use a remote image location that uses http and does not redirect to https, and an https one for the other. I can think of more suggestions but the reasons may vary and lots of them are included in the other question, so please see if that is useful first.

more options

Tonnes, you are beautiful! So I read the "this question" thread and in it I was lead to a link that talked about anti-virus.

I turned off Kaspersky and went to an email and saw the images. And I turned Kaspersky back on, and went to the same email and saw the images.

However, other emails do NOT show their images with Kaspersky on. If I turn off Kaspersky then those emails show.

The Help-->> What's New was displaying as text, until I turned off Kaspersky and then tried it.

So I suspect that Kaspersky is affecting certificates, but I know nothing about them.

I will have to turn off Kaspersky and go through my mail clicking on the different regular senders to make Thunderbird show the images, and then turn Kaspersky back on.

I hope this all makes sense.

Heartdaughter

more options

I suppose this problem is solved as far as Thunderbird is concerned because the problem is caused by Kaspersky Internet Security 2018.

Here is the thread I started on the KIS forum.

Greetings everyone.  I did reply to two other topics but I feel these three problems need to be addressed on one thread.

Kaspersky Internet Security 18.0.0.405 (c)


1. Blocks images in emails that we have given Thunderbird permission to show. Note: no error message, just a box with broken image where image should be

2. Web page will not open at all in Firefox with error code: SEC_ERROR_REUSED_ISSUER_AND_SERIAL - note: Even on google so the certificate is not being reused.

3. Web pages loading as text only in Firefox.

To fix the error in every case I have to pause KIS18 and reload the page or email and then resume KIS18.

I read on one of the other threads that linked to an involved solution about copying and pasting something to do with certificates, and my hair caught on fire. I cannot jump through those hoops for every web page and every email sender. In my opinion these three problems are related and KIS18 needs to fix them please.

I am a happy KIS user since 2011.

Heartdaughter

and the link https://forum.kaspersky.com/index.php?/topic/376185-three-problems-kis-18-needs-to-fix/

more options

Well well, security software after all (or antivirus software - I consider it to be part of it), in this case. Good to know. :)

I was still looking at Kaspersky’s support site and other places (and meanwhile found this recent thread at mozillaZine, probably about the same issue) in order to find "the" option for image or content blocking, but didn’t know the exact product until now. Given that you also experienced issues in the pages loading in Thunderbird and the fact you wrote your antivirus program does not handle email at all, that was a good lead. Altogether, you seem to have found your way to Kaspersky’s forum and presumably the support articles too so in some way this issue could be seen as solved, if only the exact way of solving it would be known so it may be good to await the outcome of your post at their forum before marking it as such. Must say I was surprised to see you also suffer issues in Firefox... ;)

There is no mention of this issue on this Mozilla wiki page for Thunderbird that was also mentioned in the other question (yet), but we should make sure to add it if a solution takes long, though I can’t imagine it will due to Firefox being affected too. Something tells me the culprit option can be found at this support page at Kaspersky, but it would be nice to know which one it is exactly - there are just too many to check and I don’t use the product.

The workaround could be to disable some feature, or to add an exception for Thunderbird. I won’t say it’s best if you disable KIS entirely or get rid of it but for email scanning, some have their doubts about whether or not it is good to enable it. This issue is more related to web/remote content in general, so basically that doesn’t apply.

For Firefox, there is a mention of Kaspersky (in general and for 2015 and 2016 versions) on this page including the SEC_ERROR_UNKNOWN_ISSUER error and a quick step to resolve that. There was a mention of the SEC_ERROR_REUSED_ISSUER_AND_SERIAL error in this KB for Firefox, but it got removed in some revision, I think because it should no longer occur in recent FF versions, but obviously it does, and it’s still in the code.

What can I say more, please keep us posted for the final solution, and thanks for investigating and feeding back.

Small nit: this forum has a bug: if a line starts with a space, a horizontal scrollbar appears, so you might want to remove that for your last post if you want to get rid of it. ;)

more options
Small nit: this forum has a bug: if a line starts with a space, a horizontal scrollbar appears, so you might want to remove that for your last post if you want to get rid of it. ;)
That is, IMHO, a feature not a bug.
  1. 1
  2. 2