Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I would like to download Firefox 2.0 for use with a legacy networking device

  • 1 odgovor
  • 1 ima ovaj problem
  • 3 views
  • Posljednji odgovor poslao Moses

more options

I have an older networking device that requires an older browser to work correctly. Each time an updated comes in I lose more and more functionality. According to the documentation I can use Firefox 1.5, 2.0 or IE 7.0. Is ther esomewhere that I can DL an older version of FF to use for this device?

All Replies (1)

more options

My god, what kind of device would prompt you to use such an old version of Firefox? I do NOT recommend downloading Firefox 2.0 for ANY device. It's just not secure or stable.

Izmjenjeno od strane Moses