Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 38.0.1 - Slowness after updating

  • 9 odgovori
  • 11 ima ovaj problem
  • 1802 views
  • Posljednji odgovor poslao ideato

more options

No matter if a newstart with firefox in secure mode with deactivated addons should maybe fix this slowness problem, firefox 38.0.1 works not well in comparison to firefox 37.0.2 or some mozilla firefox update-versions before ! Within the last a half a year all firefox updates down to firefox 36 were working well to all plugins and addons.

Izabrano rješenje

Hello,

it is the hardware acceleration issue, you have to disable hardware acceleration because affect some users with vga drivers, the problem will be solved in 2nd June, in 38.0.5 firefox release, please see : Firefox is slow after updating to Firefox 38

note that in safe mode except extension and hardware acceleration is disable. :-)

thank you

Pročitajte ovaj odgovor sa objašnjenjem 👍 3

All Replies (9)

more options

Hello!

Please take a look at the following link: https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster

This should assist you with speeding up Firefox

more options

Hello Microrobot,

thank you for your message. But I think this should not solve my problemm because I do not have any of those problem issues as described in this link you have noticed.

I have installed windows new on my pc and I have noticed this problems with firefox and slowness only since firefox 38.0.1 and not before. I have started firefox in secure mode with deactivated addons too, but at the moment it did not solve this problem issue.

pemigabo123

more options

Hello! pemigabo123

If you are using an HDD I would try defragmenting your hard-drive. Depending on the amount of data and fragmentation level it will take a good amount of time.

A good free defragment software that I recommend is called Defraggler and you can download it here : https://www.piriform.com/defraggler

Hope it helps!

more options

Hello Microrobot,

thank you for your message.

I think it do not need to defragment my hard-disk. This problem issue is only about synchronizing mozilla firefox and plugins for example shockwave player and shockwave flash.

But if the problem issue is a little bit more than usual, I want to post it to mozilla support team because of some information.

Thank you for your help and your support.

pemigabo123

more options

Separate Issue: Update your Flash Player Version 17.0.0.188
https://www.adobe.com/products/flashplayer/distribution3.html

See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration


Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

more options

Odabrano rješenje

Hello,

it is the hardware acceleration issue, you have to disable hardware acceleration because affect some users with vga drivers, the problem will be solved in 2nd June, in 38.0.5 firefox release, please see : Firefox is slow after updating to Firefox 38

note that in safe mode except extension and hardware acceleration is disable. :-)

thank you

more options

Hello FredMcD,

thank you for your message.

I have all plugins updated with actual versions and I have been updating all plugins at several times so that this would not cause any problem issue with old plugin-versions.

pemigabo123

more options

Hello ideato,

thank you for your message. With disabled hardware acceleration firefox now works better. Thank you for your support.

pemigabo123

more options

you are welcome