Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Video Automatically Plays Regardless of Settings

  • 3 odgovori
  • 46 ima ovaj problem
  • 3349 views
  • Posljednji odgovor poslao Bulldogger

more options

In Firefox for Android 37.0.1 running on Android 4.4.4, video automatically plays on the CNN website regardless of settings.

Specifically: In Settings > Display, I removed the check mark from "Allow autoplay" and in Settings > Display > Plugins, I selected "Tap to play." Nevertheless, video automatically plays on the CNN website. I don't have this problem with Chrome for Android or the Dolphin browser.

Izabrano rješenje

Although some may disagree with my preference for CNN, to each their own. The fact remains I don't have this problem with other Android browsers, so this means I can't use Firefox as my default browser.

EDIT: Upon further research I have discovered that the media.autoplay.enabled config setting has been broken or useless for years and the Firefox devs seem to have little or no interest in fixing it. See particularly the comments to https://bugzilla.mozilla.org/show_bug.cgi?id=659285.

I uninstalled Firefox for Android.

Pročitajte ovaj odgovor sa objašnjenjem 👍 10

All Replies (3)

more options

HTML video is not a plugin.

You can try setting media.autoplay.enabled to false in about:config.

more options

Thanks for your help.

It seems to me that I shouldn't need to go to about:config when I already removed the check mark from "Allow autoplay."

Nevertheless, media.autoplay.enabled is already set to false in about:config. If there is another setting you can suggest I'll try it.

more options

Odabrano rješenje

Although some may disagree with my preference for CNN, to each their own. The fact remains I don't have this problem with other Android browsers, so this means I can't use Firefox as my default browser.

EDIT: Upon further research I have discovered that the media.autoplay.enabled config setting has been broken or useless for years and the Firefox devs seem to have little or no interest in fixing it. See particularly the comments to https://bugzilla.mozilla.org/show_bug.cgi?id=659285.

I uninstalled Firefox for Android.

Izmjenjeno od strane Bulldogger