Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Is blocking 3rd party cookies preventing some icons on sites' menus from showing?

  • 1 odgovor
  • 1 ima ovaj problem
  • 2 views
  • Posljednji odgovor poslao cor-el

more options

I've noticed a problem in last several Fx versions where certain sites' menus & internal links - don't show icon images (for some). Like menus on a credit card site, once logged in. Or certain webmail menu icons.

Or HP's community forum - the text editor (to add a question) menu icons - once logged in. https://h30434.www3.hp.com/t5/custom/pa ... .hp.com%2F

It's relatively few sites - but some are important. I also noticed that any icons / images that are a problem in Fx, display in IE 9, though IE settings show 3rd party cookies blocked.

Tried a new, clean profile w/ the Fx install I was using (35.0.1). All the icon images (on sites that previously had problems) seemed to display, as long as "Accept Cookies from site" was checked & 3rd party cookies were allowed.

In the clean profile, disabling 3rd party cookies seemed to cause some icons not to show. But in IE, 3rd party cookies are "supposedly" blocked, & the icons display in it. Obviously, the problem isn't addons - problem can be reproduced in clean profile.

Also tried a clean Fx install in another folder. Same results as above - as with my old Fx install & a clean profile.

[img]http://i58.tinypic.com/2yknaeh.gif/img

[img]http://i60.tinypic.com/1zlvsox.gif/img

I've noticed a problem in last several Fx versions where certain sites' menus & internal links - don't show icon images (for some). Like menus on a credit card site, once logged in. Or certain webmail menu icons. Or HP's community forum - the text editor (to add a question) menu icons - once logged in. https://h30434.www3.hp.com/t5/custom/pa ... .hp.com%2F It's relatively few sites - but some are important. I also noticed that any icons / images that are a problem in Fx, display in IE 9, though IE settings show 3rd party cookies blocked. Tried a <u>new, clean</u> profile w/ the Fx install I was using (35.0.1). All the icon images (on sites that previously had problems) seemed to display, as long as "Accept Cookies from site" was checked & 3rd party cookies were allowed. In the clean profile, disabling 3rd party cookies seemed to cause some icons not to show. But in IE, 3rd party cookies are "supposedly" blocked, & the icons display in it. Obviously, the problem isn't addons - problem can be <u>reproduced</u> in clean profile. Also tried a clean Fx install in another folder. Same results as above - as with my old Fx install & a clean profile. * [img]http://i58.tinypic.com/2yknaeh.gif[/img] * [img]http://i60.tinypic.com/1zlvsox.gif[/img]

Izmjenjeno od strane JoeB

Izabrano rješenje

No.

Missing icons are usually supplied by a font that is downloaded from the server (@font-face) as you might see by little boxes that show the hex code of the characters instead.

Make sure that you allow pages to choose their own fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

You can check the gfx.downloadable_fonts.enabled pref on the about:config page and make sure that it is set to true (if necessary double-click the line to toggle its value).

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Pročitajte ovaj odgovor sa objašnjenjem 👍 0

All Replies (1)

more options

Odabrano rješenje

No.

Missing icons are usually supplied by a font that is downloaded from the server (@font-face) as you might see by little boxes that show the hex code of the characters instead.

Make sure that you allow pages to choose their own fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

You can check the gfx.downloadable_fonts.enabled pref on the about:config page and make sure that it is set to true (if necessary double-click the line to toggle its value).

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.