Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

The firefox window opens with no icons visible, just a black window

  • 3 odgovori
  • 11 ima ovaj problem
  • 1 view
  • Posljednji odgovor poslao philipp

more options

Hi,

When I open the firefox browser the window doesn't show me any icons, it's literally a black window.

If I hover over where File or Edit buttons would be I can see a sort of shadow of the options menu that would usually appear, however there are literally no buttons or names visible. I've done the obvious; uninstalled and re-installed, restarted the computer etc.

Please help.

Thanks Dan

Izabrano rješenje

hello dan, other users with this problem all had an embedded intel hd2000/3000 graphics card with an old driver present. in case this also applies to you, here would be a link to update the driver, which in turn should also address the black firefox problem: https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=23764 (for win7 64 bit)

in case this doesn't solve the issue or does not apply to your system, start firefox into safemode by pressing the shift key while the application is launching & disable hardware acceleration in the firefox menu ≡ > options > advanced > general (that setting will take a restart of the browser to take effect).

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

Pročitajte ovaj odgovor sa objašnjenjem 👍 7

All Replies (3)

more options

Odabrano rješenje

hello dan, other users with this problem all had an embedded intel hd2000/3000 graphics card with an old driver present. in case this also applies to you, here would be a link to update the driver, which in turn should also address the black firefox problem: https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=23764 (for win7 64 bit)

in case this doesn't solve the issue or does not apply to your system, start firefox into safemode by pressing the shift key while the application is launching & disable hardware acceleration in the firefox menu ≡ > options > advanced > general (that setting will take a restart of the browser to take effect).

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

more options

Thank you Philip, it's working. Although I'm still a little stunned as to why it happened!

Appreciate it,

Dan

more options

hi dan, this happened with the firefox 33 update, which contains a new technology which will make the browser become more responsive relying on your graphics hardware: http://benoitgirard.wordpress.com/2012/05/15/off-main-thread-compositing-omtc-and-why-it-matters/ however with certain graphic cards & old drivers it unfortunately appears to be buggy and lead to the black screen you've observed. sorry for the troubles this has caused...