Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why do FF menu entries turn black when I mouse over them?

  • 9 উত্তরসমূহ
  • 10 এই সমস্যাটি আছে
  • 1217 দেখুন
  • শেষ জবাব দ্বারা djmast

more options

FF19, Win 7 w/updates, ATI Radeon 5750 w/latest Catalyst drivers.

FF menus initially display correctly with black text on a white background. When I mouse over the text, enabled menu entries turn to black text on a black background. The active menu entry is displayed correctly but when the mouse leaves it, the entry stays black until the mouse leaves the menu, then the entire menu reverts to a correct display. Greyed out menu entries show as grey text on a black background.

The h/w acceleration option doesn't seem to affect the problem.

All Replies (9)

more options

Are you using the default theme or a third party theme? If you use only the default theme, you could put some code into a userChrome.css file in a chrome subdirectory in Firefox's profile. I think this should do:

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); 

menu:hover,
menuitem:hover{
  background: #FFFF80;
  color: #000;
}

menu[disabled="true"],
menuitem[disabled="true"],
menu[_moz-menuactive="true"][disabled="true"],
menuitem[_moz-menuactive="true"][disabled="true"] {
  color: #808080;
  background: #FFF;
}

You can change the colours to suit you.

http://kb.mozillazine.org/UserChrome.css

finitarry দ্বারা পরিমিত

more options

Try to disable hardware acceleration in Firefox.

more options

cor-el,

Thanks for the suggestion, but please read the original post a little more carefully. I did mention that this doesn't solve the problem. Sorry.

djmast দ্বারা পরিমিত

more options

Finitarry,

Nice try. I reverted to the default theme and tried other random themes but the behaviour doesn't change.

I implemented the code you suggested, shut down and restared FF, and the only effect it seemed to have is that alternate menus display in the menu bar colour instead of black. Submenus perform the same as their parent menus. Otherwise, same behaviour. How do I know the code actually being executed?

Another symptom that I just noticed, possibly unrelated, is that I cannot select a Persona from the Tools menu. I can navigate to the menu entry but when I move my mouse over a Persona, FF flashes the Persona, as if previewing, reverts to the current one and closes the menus. I can't actually select a Persona from any of the Persona sub-menus other than default.

djmast দ্বারা পরিমিত

more options

Could it be a corrupt localstore.rdf file in the profile?

more options

finitarry,

Nope. Followed the instructions and there was no appreciable effect. Some menus didn't change to back but the menu item selection highlighting stayed active on every menu item I moused over. Other menus still turned black.

Gone back to the original localstore.rdf.

more options
more options

Having the same problem with Win7 and switchable Intel HD 4000/Radeon HD 7670M. I had Firefox set to high performance in Catalyst Control Centre. Changing this to power saving solves the problem for me. However, this is not an ideal solution because full-screen video (BBC iPlayer/YouTube) is less good as a result. This is my first contribution here and I'm just hoping it provides a useful clue as to what's happening.

more options

finitarry,

Sorry for the long delay. The instructions you posted have taken me a while to go through.

1. Firefox restarted many times and doesn’t solve the problem 2. I don’t see how history and cookies could cause this, but done anyway. No change. BTW I changed the theme but it was also without any joy. 3. Started in Safe Mode. Same behaviour. 4. If the behaviour appears in Safe Mode, then the plug-ins aren’t the problem. However, I updated the ones FF said were old. No affect. 5. I'll leave resetting and reinstalling until all other avenues are exhausted but this might be the only remaining approach.

I thought that the problem must be with the video card/drivers although I have the latest ones from ATI. I've changed the resolution and refresh rate, altered the performance, 3D and AA settings but still can't alter FF's behaviour.

Thanks for trying.