সহায়তা খুঁজুন

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Public wifi login does not work with Bitdefender under Windows 10

  • 3 উত্তরসমূহ
  • 1 এই সমস্যাটি আছে
  • 11 দেখুন
  • শেষ জবাব দ্বারা Bruce Girton

more options

When logging on to public wifi network that requires a login name and password from my Windows 10 laptop with Firefox set as the default browser, my internet security application (BitDefender) shows a suspicious connection warning and blocks every effort to connect. When I try to log in with Chrome set as the default browser, the process works normally, that is, the network login page opens automatically and Bitdefender does not display a warning. I don't want to have to change my default browser every time I connect to WiFi in a coffee shop or an airport. This has been bothering me for years. Do you have any suggestions?

When logging on to public wifi network that requires a login name and password from my Windows 10 laptop with Firefox set as the default browser, my internet security application (BitDefender) shows a suspicious connection warning and blocks every effort to connect. When I try to log in with Chrome set as the default browser, the process works normally, that is, the network login page opens automatically and Bitdefender does not display a warning. I don't want to have to change my default browser every time I connect to WiFi in a coffee shop or an airport. This has been bothering me for years. Do you have any suggestions?

All Replies (3)

more options

Hello,

You might be able to whitelist local IPs in Bitdefender. If you can't do that, or override its blocking, then you might want to change security software or not use any.

They may just have a special whitelist for Chrome. Looking back, it looks like Bitdefender accidentally blocked all https access in Chrome two years ago.

more options

Hmm, it's puzzling that BitDefender jumps in only on one browser when presumably the identical thing is happening in all the browsers: the address you request gets redirected to or replaced by an authentication page generated by the wifi hotspot.

One thing Firefox may be doing differently is attempting to detect such a hotspot authentication requirement in advance of you directing it to a specific URL. Try turning that off to see whether it makes any difference:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste portal and pause while the list is filtered

(3) Double-click the network.captive-portal-service.enabled preference to switch the value from true to false

more options

I will check these ideas out tomorrow. Thanks for your time and effort.

Some tweak to the whitelist seems like a possibility, if I can figure out how. It was not working the way I expected this morning. I like Bitdefender. It's generally not bothersome, except when I am trying to figure out how to get it to let me do something it would rather not let me do, and even then it's usually more than half right. For example, the number of web sites that do not have their security certificates set up properly is sometimes annoying, but I'd rather deal with the warnings than one time get redirected somewhere unexpected and evil.

The suggestion about the authentication detection sounds hopeful. It seems to me that may be where things are going haywire.