Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Which version of Firefox is compatible with Selenium?

  • 2 replies
  • 2 have this problem
  • 77 views
  • Last reply by Bezaile

more options

I'm trying to run automated Python tests from the cmd prompt. Every time I try, I get an error message stating "Failed to start new browser session: Error while launching browser." I've updated everything - Java version 1.7.0_25, selenium library 2.9.1... I've installed older versions of Firefox back to 14.0, and nothing works. I need some help, and I don't understand any of the solutions I find online. I don't write the tests myself - we outsource to a programmer who writes everything to Github, I pull the files and run the tests.

I got a new computer - went from Windows XP to 7. Everything worked on the old computer, but I couldn't upgrade from Firefox 3.6 without the tests failing. Nothing works on the new computer, and I don't believe I should have to revert back to version 3.6 to get the tests to run.

Any help would be appreciated.

Thank you.

Chosen solution

I already have the Selenium web driver installed, and the most recent version of java. I had to go back to 3.6, and worked my way up from there. Version 12.0 is the most recent version that works for me.

Read this answer in context 👍 0

All Replies (2)

more options

Either try updating your Java libraries or add the web driver for selenium

more options

Chosen Solution

I already have the Selenium web driver installed, and the most recent version of java. I had to go back to 3.6, and worked my way up from there. Version 12.0 is the most recent version that works for me.