Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to remove the search bar in the tab strip?

  • 12 replies
  • 17 have this problem
  • 46 views
  • Last reply by minas

more options

My latest firefox update includes a search bar IN THE TAB STRIP on top of the page (not the one in the navigation toolbar). It takes up too much space for the tabs and it is useless (since there is already a search bar below it in the navigation toolbar). How do I remove it?

Modified by Jeffisgood

Chosen solution

hello, can you try to replicate this behaviour when you launch firefox in safe mode once? if not, maybe an addon is interfering here...

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

Read this answer in context 👍 4

All Replies (12)

more options

Chosen Solution

hello, can you try to replicate this behaviour when you launch firefox in safe mode once? if not, maybe an addon is interfering here...

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

more options

Sorry, that search box in the tab strip wasn't part of the Firefox update, but rather probably came as a result of an Add-on update as the new version of Firefox was installing itself on the restart. You didn't provide the Troubleshooting Information as requested when you created this thread, so I can't look through that information for the possible name of the extension that most likely included that "extra".

See this - https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
Hopefully you will be able to figure out which extension is at fault with a little bit of troubleshooting.

more options

Please post a screenshot so that we can see what the problem is.

Is it is the standard search bar,that has options to use differing search engines, then that can be removed easily:

  1. right click an empty space on a toolbar
  2. use the customise option
  3. drag the toolbar off and on to the options palette
more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.
more options

I was able to fix the problem in Safe Mode. It was an extension disguised as a Firefox original part, named itself as "firefox default tabs." I am not sure how I got it since I have not downloaded anything recently. My Kaspersky did not block anything as well. But, huge thanks!

more options

It was not a Firefox toolbar function so I could not customize it. But I was able to fix it in Safe Mode since it was probably a malicious add-on. Thanks!

more options

I was already suspecting this and it might have helped if you had included an extension list (Troubleshooting Information).

more options

I was also able to fix this in the same way, however for me, the pesky add on was named 'Default Tabs 2.0'.

more options

You don't actually have to go in to safe mode to do this, or at least I didn't. I just went to my extensions and disabled the "default tabs" extension.

more options

Safe mode is only intended as a troubleshooting aid. Safe mode helps to indicate what it is that causes a problem, and one of its actions is to disable all extensions. Often problems are caused by extensions that have been installed because they came bundled with something and the offer to install the bundled software was not refused.

Always take care when installing software that you do not get extras that you do not really want.

more options

Simply go to Addons >>Extensions

Look for Default Tab

Then just disable and remove it!

Easy peasy!

more options

Hi, i managed to remove that annoying add like KaraGirl said from my extensions also named 'Default Tabs 2.0'. Just to let you know i got this when installed "zoom player". This "websearch" something wouldnt let me to open google.com at all. Attached you can find how this looks like. Thank you for your help really ;)