Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Button clicks do not work with hotmail. How can this be fixed? This is not a problem with MS IE.

  • 2 replies
  • 1 has this problem
  • 1 view
  • Last reply by terrace500

more options

When I log into hotmail with Firefox i am unable to open mail or go to my inbox. Left clicks do not work. This is not a problem when I log into hotmail with Internet Explorer. This started occuring yesterday, 11/29/12.

Chosen solution

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

(You also can clear Firefox's cache completely using:

orange Firefox button or Tools menu > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now")

(2) Remove the site's cookies (save any pending work first) using either of these. While viewing a page on the site:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

Then try reloading the page. Does that help?

---

Some add-ons have a reputation for invisibly blocking clicks on the top part of a page. If you notice that on other sites, i.e., not just live.com, then it could be one of your extensions.

Read this answer in context 👍 0

All Replies (2)

more options

Chosen Solution

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

(You also can clear Firefox's cache completely using:

orange Firefox button or Tools menu > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now")

(2) Remove the site's cookies (save any pending work first) using either of these. While viewing a page on the site:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

Then try reloading the page. Does that help?

---

Some add-ons have a reputation for invisibly blocking clicks on the top part of a page. If you notice that on other sites, i.e., not just live.com, then it could be one of your extensions.

more options

This solution worked. Thanks for the help.