Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Type Error: Yahoo.widget.overlay is not a constructor. Only get error in Firefox, and started this morning.

  • 4 replies
  • 2 have this problem
  • 48 views
  • Last reply by Mule

more options

There was an automatic Windows update this morning. Since then, I get the error message "TypeError: Yahoo.widget.overlay is not a constructor" when I open up certain websites, such as ancestry.com. Other sites, such as Facebook, don't work at all. Everything appears scrambled when I open the website. Other sites appear to not be affected, although I haven't done more than open them up. These errors are only occurring with Firefox, and not with IE. IE still works just fine.

There was an automatic Windows update this morning. Since then, I get the error message "TypeError: Yahoo.widget.overlay is not a constructor" when I open up certain websites, such as ancestry.com. Other sites, such as Facebook, don't work at all. Everything appears scrambled when I open the website. Other sites appear to not be affected, although I haven't done more than open them up. These errors are only occurring with Firefox, and not with IE. IE still works just fine.

Chosen solution

A friend just gave me a tip which solved this problem. I went to the Options menu, Content, and unchecked the box that said "Enable Java Script." I have no idea why this worked, but it solved the problem and all the websites appear to be working fine again.

Read this answer in context 👍 0

All Replies (4)

more options

I have the same problem, Firefox 15 Windows 7 64 Bit

more options

Sounds like a problem with an Yahoo extension (toolbar)

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.
more options

Thanks for the suggestion, but unfortunately it didn't work. The same problems occur in safe mode as well.

more options

Chosen Solution

A friend just gave me a tip which solved this problem. I went to the Options menu, Content, and unchecked the box that said "Enable Java Script." I have no idea why this worked, but it solved the problem and all the websites appear to be working fine again.