Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

The same websites always open in Firefox. How do I remove them?

  • 3 replies
  • 1 has this problem
  • 9 views
  • Last reply by Evan

more options

I have Firefox 12.0. Recently when I open Firefox the same five websites always open. I've cleared my cache, cookies and history, and individually deleted the webpages from history, but they always return. Three computers which are synced all have this problem. Any suggestions?

Thanks. Evan

Chosen solution

One possibility is that all five have gotten saved as home pages. One way to test this theory is to press Ctrl+n to open a new window. If the same five tabs appear, please check here:

orange Firefox button or classic Tools menu > Options > General

Where you see "Home Page" do you see multiple URLs there? If so, you can edit that line, or just delete everything to use the default Firefox home page.

If you don't see multiple URLs there, is it possible that an old session keeps coming back (like Groundhog Day)?

Read this answer in context 👍 0

All Replies (3)

more options

Chosen Solution

One possibility is that all five have gotten saved as home pages. One way to test this theory is to press Ctrl+n to open a new window. If the same five tabs appear, please check here:

orange Firefox button or classic Tools menu > Options > General

Where you see "Home Page" do you see multiple URLs there? If so, you can edit that line, or just delete everything to use the default Firefox home page.

If you don't see multiple URLs there, is it possible that an old session keeps coming back (like Groundhog Day)?

more options

See these articles for some suggestions:

more options

Thanks jscher2000, that was it. Some how all five got saved together.