Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Startup homepages are overwritten; overwrites custom settings

  • 4 replies
  • 3 have this problem
  • 218 views
  • Last reply by jhaaga

more options

I am running FF 6.0.2 on Windows XP Professional Service Pack 3 on a network, but FF is installed on my local machine. I set my start pages to Yahoo and Google News, but FF overwrites my settings. Each time I reset my preferences and start the browser it displays the whats new and first run tabs. It seems to treat each instance as a brand-new install.

I had disabled or removed all of my addons and basically started with a "safe" firefox in case there was some conflict, but that didn't help.

My bookmarks and security passwords settings do not change, but it reverts to "Remember history" when I use the "Custom settings" option in the Privacy window.

The about:config settings for browser.startup and startup.homepage are:

browser.startup.homepage_override.buildID; user set; string; 20110902133214

browser.startup.homepage_override.mstone; user set; string; rv:6.0.2

startup.homepage_override_url; default; string http://www.mozilla.com/%LOCALE%/%APP%/%VERSION%/whatsnew/

startup.homepage_welcome_url; default; string; http://www.mozilla.com/%LOCALE%/%APP%/%VERSION%/firstrun/

I am running FF 6.0.2 on Windows XP Professional Service Pack 3 on a network, but FF is installed on my local machine. I set my start pages to Yahoo and Google News, but FF overwrites my settings. Each time I reset my preferences and start the browser it displays the whats new and first run tabs. It seems to treat each instance as a brand-new install. I had disabled or removed all of my addons and basically started with a "safe" firefox in case there was some conflict, but that didn't help. My bookmarks and security passwords settings do not change, but it reverts to "Remember history" when I use the "Custom settings" option in the Privacy window. The about:config settings for browser.startup and startup.homepage are: '''browser.startup.homepage_override.buildID; user set; string; 20110902133214''' '''browser.startup.homepage_override.mstone; user set; string; rv:6.0.2''' startup.homepage_override_url; default; string http://www.mozilla.com/%LOCALE%/%APP%/%VERSION%/whatsnew/ startup.homepage_welcome_url; default; string; http://www.mozilla.com/%LOCALE%/%APP%/%VERSION%/firstrun/

All Replies (4)

more options

Chosen Solution

more options

Thanks, after posting I found both of these site. Unfortunately, they didn't help. There is no user.js file in the profile folder. It seems that FF didn't create a prefs-js file automatically, as that file is not in the profile folder, either.

more options

Does Firefox create a new file prefs.js with the correct time stamp after you close Firefox?

Are there any files prefs-##.js with a number in the name or a file user.js in the profile folder?

  • Help > Troubleshooting Information > Profile Directory: Open Containing Folder

Create a new profile as a test to check if your current profile is causing the problems.
See Basic Troubleshooting: Make a new profile:

If that new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files

See:

more options

Thanks for the suggestions. It seems that for some reason Firefox was not creating a prefs.js file and there was no user.js file.

I'm not sure why, but after a week or so, a prefs.js was created and all is now well.

Thanks again.