Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Always prompted for action even though "Do this automatically" is checked.

  • 3 replies
  • 29 have this problem
  • 732 views
  • Last reply by snapz

more options

Hi,

I have actions set to open PDF files in Adobe Acrobat 9.4; all things Adobe or PDF in the Options->Applications are set to "Adobe Acrobat 9.4 (default)".

Whenever I click on a PDF link in a page I *still* get the popup window asking me "What should Firefox do with this file". This dialog box has "Adobe Acrobat 9.4 (default)" selected for "Open with" and the "Do this automatically for files like this from now on" is checked. (FWIW I have also used the Adobe Acrobat 9.4 that doesn't have the "(default)" after it too.).

I can't seem to figure out how to make it open my PDFs in Acrobat without ALWAYS prompting me with the dialog box. Is there any way to have it just open Acrobat and the document without this additional prompting? It did this in the 3.whatever version I had and now too in the 4.0.1 version.

All Replies (3)

more options

See "File handling in Firefox 3 and SeaMonkey 2"

Setting an automatic action only works for a specific MIME type and not for a file extension.

more options

I fixed this once before and now with Fox 4, I had to remember it again.

Go to Tools and Add-Ons Then open the Plugins Then disable the Adobe Acrobat plugin Close then open Tools / Options and find the Adobe Acrobat under "Content Type" and click the selection to the right to select your Acrobat Pro software.

more options

The InlineDisposition add-on fixes the "do this automatically..." problem.

https://addons.mozilla.org/en-US/firefox/addon/inlinedisposition/