Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Translates automatically to Spanish (which I don't speak)

  • 1 reply
  • 2 have this problem
  • 1 view
  • Last reply by cor-el

more options

Ever since updating to 3.6, my web pages are not automatically in Spanish, and I have to go through the painstaking task of clicking, for each page, translate back to English. This happens even with a site that might have multiple pages, like a TV station, book site (Amazon), Facebook. This is happening with all my already-bookmarked sites, which I've had for ages.

I do not speak Spanish, have never had Spanish translation, and would never, to the best of my knowledge, change any page to translate to Spanish. I do not have a Spanish surname - far from it, not even remotely!!

So....why is this happening, and am I gonna have to deal with this for every site I visit? This is ridiculous!!

Modified by Phooey

All Replies (1)

more options

That is a feature offered by the Google Toolbar.

See http://www.google.com/support/toolbar/bin/answer.py?answer=20871 - Translate : Translate basics - Toolbar Help

You may need to reinstall the latest version of the Google Toolbar.

http://www.google.com/tools/firefox/toolbar/FT5/intl/en/
http://tools.google.com/tools/firefox/toolbar/FT5/intl/en/install.html