Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Update

  • 4 replies
  • 0 have this problem
  • 10 views
  • Last reply by cor-el

more options

Hello, since the last FF update a week or so ago, I am now required to log in to EVERY single site that I seem to go to (AOL, Facebook, Twitter, Weebly (my own web site), and many others). Before the update, I would only need to log in to these web sites every so often. Is there something I can do to eleviate this? Thank you.

Hello, since the last FF update a week or so ago, I am now required to log in to EVERY single site that I seem to go to (AOL, Facebook, Twitter, Weebly (my own web site), and many others). Before the update, I would only need to log in to these web sites every so often. Is there something I can do to eleviate this? Thank you.

All Replies (4)

more options

This could be caused by using private windows in Firefox. If you have used the new private browsing icon, you might want to switch back to using the regular icon.

Or if you are using the regular icon and Firefox still doesn't retain cookies (it's the cookies that sites use to recognize that you already signed in), you can check your Settings page, Privacy & Security panel, to make sure Firefox is set to retain them. Here's how:

Cookies and Site Data

If you have a check mark for "Delete cookies and site data when Firefox is closed" then you need to create an exception using the "Manage Exceptions" button (or when you are on the site, you can use the Page Info dialog, Ctrl+i, Permissions list, under "Set cookies" uncheck "Use default" and select "Allow" to create the exception).

History

There's a general selector:

  • Firefox will: Remember history => should be okay
  • Firefox will: Never remember history => prevents saving cookies for your next session
  • Firefox will: Use custom settings for history => need to check the details

With custom settings:

[_] Always use private browsing mode => must be un-checked [?] Clear history when Firefox closes => use the Settings button to check what is being cleared and make sure that "Cookies" are not set to be cleared

Helpful?

more options

Should I uncheck the "delete cookies and site data..."? I went to the History and it said "use custom settings" so I changed it to remember history. I will see how it works out. Thank you so much. It was frustrating having to log in each and every single time. My aunt was also having the same issue although she didn't know it until explaining it to me earlier today. Thanks again.

Helpful?

more options

It's up to you whether you want to delete most cookies, but if you use that setting, you need to create exceptions for sites where you want to stay signed in.

Helpful?

more options

Note that you should also keep the "Site settings".

You can check that you aren't clearing important cookies.

  • using "Delete cookies and site data when Firefox is closed" to clear cookies keeps cookies with an allow exception
    in 102+ version toggling this setting makes changes to the "Clear history when Firefox closes" settings and those settings prevail
  • using "Clear history when Firefox closes" in Firefox 102+ honors exceptions and keeps cookies with an allow exception, previous versions removed all cookies

Make sure to keep the "Site settings".

  • clearing "Site settings" clears exceptions for cookies, images, pop-up windows, and software installation and exceptions for passwords and other website specific data
  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Exceptions"
  • Settings -> Privacy & Security
    Firefox will: "Use custom settings for history":
    [X] "Clear history when Firefox closes" -> Settings

Modified by cor-el

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.