On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

TB 91.10 Misaligns text when sending and other odd behavior

  • No replies
  • 1 has this problem
  • 1 view
more options

I'm using Thunderbird 91.10.0

I have an e-mail account where the "Composition: Compose messages in HTML format" box is Unchecked. I construct the body of an e-mail to be sent using a plain text editor (Kedit for Windows). The text of this e-mail contains absolutely no special characters (and that means there are zero Tab characters in there either). I selected the text within the text editor, copied it to the Windows clipboard, and then pasted it into the (initially empty) e-mail body in Thunderbird. The e-mail was then sent (by clicking on the Send button).

Unfortunately, Thunderbird changes the e-mail body when sending which results in lines being misaligned (blanks are either inserted or removed).

When I highlight the message in the Sent folder and then click on "View -> Message Source", the misaligned e-mail is displayed in another window titled "Source of: mailbox:///C:/Tbird_RJR_Raicer/Sent?number=2793 - Mozilla Thunderbird". If I attempt to save a copy of the content of this window by clicking on "File -> Save Page As ...", the "Save As' dialog window opens as expected. However, when clicking on the Save button in that window, no file is created (I've searched the entire system and the file does not exist).

When going back to the main Thunderbird window which is displaying the Sent folder, highlighting the e-mail, and then selecting "File -> Save as -> File" the "Save Message As" window opens. I put a complete file name (full path included) in the "File Name" box, select "Text Files" from the "Save As Type:" dropdown box, and then click the Save button. The file is created as expected. When looking at this file it can be seen that Thunderbird has inserted the three byte string 0xEF, 0xBB, 0xBF as the first three bytes of the file. This is the UTF-8 representation of the Byte Order Mark. From what I've read, the Unicode Standard permits this BOM string to be present, but it is recommended to NOT inlcude it in UTF-8 streams. Throughout the remainder of the e-mail body, Thunderbird has replaced many (but not all) of the Blanks (0x20) with Non-Breaking-Spaces (the two byte sequence of 0xC2, 0xA0).

So, there are a number of issues here:

-There is clearly a defect in the code which deals with saving the e-mail content when in the "View -> Message Source" path.

-The text of the e-mail body becomes misaligned by Thunderbird when it is being sent.

-The Byte Order Mark and Non-Breaking-Spaces stuff behavior is completely undesirable (and feels plain wrong for a plain text e-mail).

How can I get Thunderbird to NOT mess with the spaces (blanks) in the e-mail body?

How can I get Thunderbird to NOT insert the BOM at the start of the e-mail file and NOT change spaces to Non-Breaking-spaces?

I can provide supporting files if you can tell me how to do so. Thanks for the help.

I'm using Thunderbird 91.10.0 I have an e-mail account where the "Composition: Compose messages in HTML format" box is Unchecked. I construct the body of an e-mail to be sent using a plain text editor (Kedit for Windows). The text of this e-mail contains absolutely no special characters (and that means there are zero Tab characters in there either). I selected the text within the text editor, copied it to the Windows clipboard, and then pasted it into the (initially empty) e-mail body in Thunderbird. The e-mail was then sent (by clicking on the Send button). Unfortunately, Thunderbird changes the e-mail body when sending which results in lines being misaligned (blanks are either inserted or removed). When I highlight the message in the Sent folder and then click on "View -> Message Source", the misaligned e-mail is displayed in another window titled "Source of: mailbox:///C:/Tbird_RJR_Raicer/Sent?number=2793 - Mozilla Thunderbird". If I attempt to save a copy of the content of this window by clicking on "File -> Save Page As ...", the "Save As' dialog window opens as expected. However, when clicking on the Save button in that window, no file is created (I've searched the entire system and the file does not exist). When going back to the main Thunderbird window which is displaying the Sent folder, highlighting the e-mail, and then selecting "File -> Save as -> File" the "Save Message As" window opens. I put a complete file name (full path included) in the "File Name" box, select "Text Files" from the "Save As Type:" dropdown box, and then click the Save button. The file is created as expected. When looking at this file it can be seen that Thunderbird has inserted the three byte string 0xEF, 0xBB, 0xBF as the first three bytes of the file. This is the UTF-8 representation of the Byte Order Mark. From what I've read, the Unicode Standard permits this BOM string to be present, but it is recommended to NOT inlcude it in UTF-8 streams. Throughout the remainder of the e-mail body, Thunderbird has replaced many (but not all) of the Blanks (0x20) with Non-Breaking-Spaces (the two byte sequence of 0xC2, 0xA0). So, there are a number of issues here: -There is clearly a defect in the code which deals with saving the e-mail content when in the "View -> Message Source" path. -The text of the e-mail body becomes misaligned by Thunderbird when it is being sent. -The Byte Order Mark and Non-Breaking-Spaces stuff behavior is completely undesirable (and feels plain wrong for a plain text e-mail). How can I get Thunderbird to NOT mess with the spaces (blanks) in the e-mail body? How can I get Thunderbird to NOT insert the BOM at the start of the e-mail file and NOT change spaces to Non-Breaking-spaces? I can provide supporting files if you can tell me how to do so. Thanks for the help.

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.