Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox restart is slow

  • 6 replies
  • 1 has this problem
  • 21 views
  • Last reply by jonzn4SUSE

more options

I've been noticing lately that Firefox takes a while to start loading pages after it requests a restart or recovers from a crash.

I've followed all the advice in the forums including disabling session restore, but the problem persists.

It seems to be doing a lot of disk activity when it restarts either after requesting a restart or if it crashes and I start it again.

Anything I can do to address this issue?

I've been noticing lately that Firefox takes a while to start loading pages after it requests a restart or recovers from a crash. I've followed all the advice in the forums including disabling session restore, but the problem persists. It seems to be doing a lot of disk activity when it restarts either after requesting a restart or if it crashes and I start it again. Anything I can do to address this issue?

All Replies (6)

more options

hello mahadevan.k,

1. Update Firefox

  1. # Click the menu button (top right 3dot) at the right side of the Firefox toolbar, click Help, and select About Firefox.
  2. # The About Mozilla Firefox window opens. Firefox will check for updates and, if an update is available, it will be downloaded automatically by default.
  3. When the download is complete, click Restart to update Firefox

2. Delete content-prefs.sqlite file Firefox stores your data in various files in your profile folder. The file used for saving individual website settings might be corrupt. If you delete (or rename) that file, your zoom level settings will be reset but it could decrease CPU usage.

Click the menu button (3 dot top right) click Help, and select More Troubleshooting Information. The Troubleshooting Information tab will open.

  • Under the Application Basics section next to Profile Folder, click
  • Open Folder Your profile folder will open.
  • Click the Firefox menu and select Exit.
  • In your profile folder, delete the file content-prefs.sqlite. It will be recreated next time you open Firefox.

Restart Pc

I hope your Issue will fixed

Thank Reagrds Arman

Helpful?

more options

I managed to solve this, I just deleted the history and it was fine.

Not sure how this problem occured though.

Helpful?

more options

Are you using "Clear history when Firefox closes" to clear data as Firefox might do this on the next start when it didn't close properly the previous time (sessionCheckpoints.json) ?

Helpful?

more options

Mark it as resolve and get back to it...

Helpful?

more options

cor-el said

Are you using "Clear history when Firefox closes" to clear data as Firefox might do this on the next start when it didn't close properly the previous time (sessionCheckpoints.json) ?
No, I wasn't using this option

jonzn4SUSE said

Mark it as resolve and get back to it...

I don't appreciate the tone here. Maybe you shouldn't be handling support?

Helpful?

more options

Hey mahadevan.k,

You are misinterpreting the statement, there was no negative tone. ;-))

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.