Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

FF Android 98 -- Pages failing to start loading, blank or confused page

  • 3 replies
  • 1 has this problem
  • 18 views
  • Last reply by Paul

more options

Over the last few weeks FF has started failing to start loading pages.

Behaviour: I tap on a link, a new tab opens, but the URL from the *previous* page remains showing in the address bar, not progress bar shows, and the page stays blank indefinitely. Reloading sometimes fixes it(?). I usually have to kill the toxic tab.

There is no pattern I can see for which pages this impacts. It's "all pages". Maybe 5% of pages. Enough to be rather annoying.

I have zero Add-ons installed. Android 12.

Tapping on the address bar shows the URL change to the new address but hitting enter it just switched back to showing the old address. No page ever loads. I can often close the tab then click on the link again, but it feels like something very early in the page loading process is dying (TLS? Some loading thread?!) and the process just ... Stops.

Switching between tabs in this state shows the same problem. Like right now I can see a Patreon URL tab that failed to load, but the tab gallery view shows the correct title but *THIS* page's content! See attached. When I tap on that Patreon tab, I get dropped back onto *this* tab. They are apparently two views of the one page now? Hard to explain, but certainly some confused state going on.

This didn't happen a month or so ago.

Any other way I can help debug this?

Thanks!

Over the last few weeks FF has started failing to start loading pages. Behaviour: I tap on a link, a new tab opens, but the URL from the *previous* page remains showing in the address bar, not progress bar shows, and the page stays blank indefinitely. Reloading sometimes fixes it(?). I usually have to kill the toxic tab. There is no pattern I can see for which pages this impacts. It's "all pages". Maybe 5% of pages. Enough to be rather annoying. I have zero Add-ons installed. Android 12. Tapping on the address bar shows the URL change to the new address but hitting enter it just switched back to showing the old address. No page ever loads. I can often close the tab then click on the link again, but it feels like something very early in the page loading process is dying (TLS? Some loading thread?!) and the process just ... Stops. Switching between tabs in this state shows the same problem. Like right now I can see a Patreon URL tab that failed to load, but the tab gallery view shows the correct title but *THIS* page's content! See attached. When I tap on that Patreon tab, I get dropped back onto *this* tab. They are apparently two views of the one page now? Hard to explain, but certainly some confused state going on. This didn't happen a month or so ago. Any other way I can help debug this? Thanks!
Attached screenshots

All Replies (3)

more options

Hi

Do you have the address of a website that you can share where this happens?

Helpful?

more options

Hi,

Per original comment, there was no pattern -- sometime a URL would work, later visits to the same page would break.

In frustration I deleted all storage in addition to cache storage. I *think* the issue has gone away after this -- I haven't seen in for a couple of hundred pages now. So something that was processed immediately prior to page loading was killing the loading process. No CPU spinning, just dead/dangling tabs.

Thanks.

Helpful?

more options

By clearing storage, you would have taken Firefox for Android back to a "first run" experience - drastic, but if it has worked, happy to take a step back on this for now

Please come back and reply to this thread if the issue reappears.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.