Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to disable search suggestions showing ahead of browsing history?

  • 1 reply
  • 1 has this problem
  • 6 views
  • Last reply by cor-el

more options

Recently I accidentally typed a bit too fast when entering a url (facebook) as I normally enter part of the url, then arrow down and press enter on the result from the drop down list - I messed up and typed "fac" and hit enter before hitting my down arrow key to result, leading me to google search the term "fac." Over... and over... and over... and over again.

Now any time I attempt to type in any url I can no longer just one arrow down and hit enter to go to the website I intended on going to, it makes me google search the website then click on it. I've gone to settings and changed the "Show search suggestions ahead of browsing history in address bar results" to off and on some attempts disabled providing search suggestions entirely. I've cleared my history of google searches for partially completed websites, google.com itself, and restarted the browser. Several times the settings wouldn't save and I would only see "Show search suggestions ahead of browsing history in address bar results" as checked with no other options checked in the settings page. Google still pops up as the lead result whenever I type anything into the address bar.

I still cannot disable this abysmal function of the browser. Any help on disabling this nonsense would be greatly appreciated so I no longer have to click on a website from google that I've visited hundreds of times prior and can just hit enter from my address bar. Maybe at least move the search engine suggestions to the bottom of the drop down and not the very first option.

Recently I accidentally typed a bit too fast when entering a url (facebook) as I normally enter part of the url, then arrow down and press enter on the result from the drop down list - I messed up and typed "fac" and hit enter before hitting my down arrow key to result, leading me to google search the term "fac." Over... and over... and over... and over again. Now any time I attempt to type in any url I can no longer just one arrow down and hit enter to go to the website I intended on going to, it makes me google search the website then click on it. I've gone to settings and changed the "Show search suggestions ahead of browsing history in address bar results" to off and on some attempts disabled providing search suggestions entirely. I've cleared my history of google searches for partially completed websites, google.com itself, and restarted the browser. Several times the settings wouldn't save and I would only see "Show search suggestions ahead of browsing history in address bar results" as checked with no other options checked in the settings page. Google still pops up as the lead result whenever I type anything into the address bar. I still cannot disable this abysmal function of the browser. Any help on disabling this nonsense would be greatly appreciated so I no longer have to click on a website from google that I've visited hundreds of times prior and can just hit enter from my address bar. Maybe at least move the search engine suggestions to the bottom of the drop down and not the very first option.
Attached screenshots

All Replies (1)

more options

You can try to set keyword.enabled = false on the about:config page.

You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue".