X
Tap here to go to the mobile version of the site.
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

Support Forum

Unable to turn of search suggestions after upgrade to Firefox 65

Posted

I was on a previous version of Firefox 64. I had about:config > browser.urlbar several settings like autocomplete and suggest searches toggled to false. My privacy settings > address bar suggestions are clear, and I never remember history, passwords, etc.

No drop down for the urlbar, no suggestions. Perfect, working good no issue.

Then an upgrade to Firefox 65 this morning and now I have the url bar dropdown. I double checked my settings and they are still like Firefox 65, yet now this is happening again.

I tried to see if there was another setting that was enabled and I can't find one. Can you suggest a fix?

I was on a previous version of Firefox 64. I had about:config > browser.urlbar several settings like autocomplete and suggest searches toggled to false. My privacy settings > address bar suggestions are clear, and I never remember history, passwords, etc. No drop down for the urlbar, no suggestions. Perfect, working good no issue. Then an upgrade to Firefox 65 this morning and now I have the url bar dropdown. I double checked my settings and they are still like Firefox 65, yet now this is happening again. I tried to see if there was another setting that was enabled and I can't find one. Can you suggest a fix?

Chosen solution

you could try creating a userChrome.css file with the following content in order to hide the addressbar dropdown-menu:

#PopupAutoCompleteRichResult {

  display: none!important;

}

https://www.userchrome.org/how-create-userchrome-css.html

Read this answer in context 1
Quote
philipp
  • Top 25 Contributor
  • Moderator
5249 solutions 23215 answers

hi, support for the browser.urlbar.autocomplete.enabled preference got removed in firefox 65 unfortunately. https://bugzilla.mozilla.org/show_bug.cgi?id=1502392

hi, support for the browser.urlbar.autocomplete.enabled preference got removed in firefox 65 unfortunately. https://bugzilla.mozilla.org/show_bug.cgi?id=1502392
Was this helpful to you?
Quote

Helpful Reply

Thanks.

I can see how this would be useful for mobile browsing, but for a desktop I find the feature distracting, I know where I am browsing to and don't need it suggested to me, I can type it faster than dropping down and selecting it.

Will they be removing search suggestions from the Search > Default Search engines also? Seems like the two go hand in hand.

Is there anyway to disable this drop down?

Thanks. I can see how this would be useful for mobile browsing, but for a desktop I find the feature distracting, I know where I am browsing to and don't need it suggested to me, I can type it faster than dropping down and selecting it. Will they be removing search suggestions from the Search > Default Search engines also? Seems like the two go hand in hand. Is there anyway to disable this drop down?
Was this helpful to you? 1
Quote
philipp
  • Top 25 Contributor
  • Moderator
5249 solutions 23215 answers

Chosen Solution

you could try creating a userChrome.css file with the following content in order to hide the addressbar dropdown-menu:

#PopupAutoCompleteRichResult {

  display: none!important;

}

https://www.userchrome.org/how-create-userchrome-css.html

you could try creating a userChrome.css file with the following content in order to hide the addressbar dropdown-menu: <code>#PopupAutoCompleteRichResult { display: none!important; }</code> https://www.userchrome.org/how-create-userchrome-css.html
Was this helpful to you? 1
Quote

Question owner

Thanks! Worked like a charm, I can now deploy that file to my other computers and get rid of that annoying drop down.

Thanks! Worked like a charm, I can now deploy that file to my other computers and get rid of that annoying drop down.
Was this helpful to you? 0
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.