Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Only one account can execute FireFox after installing 61.0.2 on Windows 10

  • No replies
  • 1 has this problem
  • 3 views
more options

I installed version 61.0.2 on my Windows 10 machine as "Administrator." At the end of the installation process, a Firefox Browser window popped up. Everything looked good so I closed the browser and looked for the icon in the Start Menu (under Recently added, also under "Firefox" and "Mozilla Firefox") and toolbar. No icons.

I repeated the same installation, but this time, when the browser popped up, I right-clicked on the icon displayed in the toolbar and selected to "Pin to taskbar." I closed the browser and I am able to relaunch Firefox by clicking on the icon in the taskbar. Still no icons in the Start Menu.

I then logged out and back into my wife's account. I could not find any evidence of the installation. I decided to see what would happen if I tried to install it from her account. I downloaded the same installer and right clicked on it and selected "Run as Administrator." The same thing happened (after installation the browser popped up), only in her account, the icon displayed in the taskbar is generic (no Firefox image). I right-clicked on it and selected to "Pin to taskbar" then closed the browser. I tried to relaunch Firefox by clicking on the icon on the taskbar but Windows said something about the item referenced by the shortcut has moved.

How can I install Firefox for all users on our Windows 10 desktop?