Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Autocomplete not working after a while unless search contains a space or backspace is used

  • 1 reply
  • 1 has this problem
  • 34 views
  • Last reply by jdepypere

more options

After a while running Firefox on my Windows 10 laptop, the combined address & search bar gets useless. When typing no autocomplete suggestions are given (even though it is enabled). But even more infuriating is that even an enter doesn't work to go to/search for what you typed. There is simply no drop-down bar that should be there containing search engines, previously visited websites, search suggestions, ... Now the funky thing is once I type a space it does get enabled (both the drop-down bar as enter) and I can continue typing away. Also pressing a backspace enables bottom-bar and enter. Worth noting is that when the autocomplete/bottom-bar is not enabled and thus enter is not working, clicking the arrow at the right of the address bar does work.

Some examples: - 'google.com' - nothing happens. No autocomplete, can't use enter to go to site. - 'google.com ' - autocomplete enabled, enter works, the world is well. - 'my custom search' - also works - 'google.comm' and then press backspace so the content becomes 'google.com' - also works

I don't think it has anything to do with search provider settings because this is also not showing websites from my history. I've also disabled the search suggestions, without avail.

After a while running Firefox on my Windows 10 laptop, the combined address & search bar gets useless. When typing no autocomplete suggestions are given (even though it is enabled). But even more infuriating is that even an enter doesn't work to go to/search for what you typed. There is simply no drop-down bar that should be there containing search engines, previously visited websites, search suggestions, ... Now the funky thing is once I type a space it does get enabled (both the drop-down bar as enter) and I can continue typing away. Also pressing a backspace enables bottom-bar and enter. Worth noting is that when the autocomplete/bottom-bar is not enabled and thus enter is not working, clicking the arrow at the right of the address bar does work. Some examples: - 'google.com' - nothing happens. No autocomplete, can't use enter to go to site. - 'google.com ' - autocomplete enabled, enter works, the world is well. - 'my custom search' - also works - 'google.comm' and then press backspace so the content becomes 'google.com' - also works I don't think it has anything to do with search provider settings because this is also not showing websites from my history. I've also disabled the search suggestions, without avail.

Chosen solution

I have found the problem and solved it.

My Firefox profile was stored on a network drive due to company policy. Every time I (un)docked my computer and/or hibernated it, I noticed the issues mentioned above. Probably Firefox would try to read/write something to/from the profile, but since this was inaccessible briefly, would somehow freeze there. The workaround solution was to change the Firefox profile location - following the steps described in this support forum topic. Another solution is to use Firefox Portable, but I personlly didn't want to use the second method since it uses SourceForge.

Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

I have found the problem and solved it.

My Firefox profile was stored on a network drive due to company policy. Every time I (un)docked my computer and/or hibernated it, I noticed the issues mentioned above. Probably Firefox would try to read/write something to/from the profile, but since this was inaccessible briefly, would somehow freeze there. The workaround solution was to change the Firefox profile location - following the steps described in this support forum topic. Another solution is to use Firefox Portable, but I personlly didn't want to use the second method since it uses SourceForge.