Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox microfreezing every few seconds

  • 2 replies
  • 13 have this problem
  • 73 views
  • Last reply by luntacarsus

more options

Yesterday Firefox decided to upgrade itself to Quantum. Since then it is constantly micro-freezing every few seconds. It works fine for a few seconds, then lags for a few seconds, then repeats. During the freezes I can't click anything, can't type anything, can't scroll, or anything. Even typing this message is taking twice as long as it should.

I've searched for the problem and done all the suggested fixes. I've disabled hardware acceleration, started the browser in safe mode, disabled all plugins, but none of these helps. Is there anything else I can try? The previous version of Firefox didn't have this problem.

Chosen solution

Ok....guess you do not follow the AMD Icon in the Task Manager for your AMD Radeon R9 200 / HD 7900 Series (I have 7970) I get updates for it monthly. Your not to far behind driverDate: 9-22-2017 Keep it updated, very important these days. Large amount of crashes I see are old drivers.

No going back unless to version 52.5.0 ESR https://www.mozilla.org/en-US/firefox/organizations/all/ Good till May 2018 only. Then poof, all old supported gone so XP, Vista gone.

So you updated.... (so did I) and since have tried Safe and such a clean install. Please uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. but just in case : https://support.mozilla.org/en-US/kb/profiles-where-firefox-stores-user-data save a copy first.

Reinstall with Current Release Firefox 57.0 with a Full Version Installer https://www.mozilla.org/firefox/all/

Please let us know if this solved your issue or if need further assistance.

Read this answer in context 👍 2

All Replies (2)

more options

Chosen Solution

Ok....guess you do not follow the AMD Icon in the Task Manager for your AMD Radeon R9 200 / HD 7900 Series (I have 7970) I get updates for it monthly. Your not to far behind driverDate: 9-22-2017 Keep it updated, very important these days. Large amount of crashes I see are old drivers.

No going back unless to version 52.5.0 ESR https://www.mozilla.org/en-US/firefox/organizations/all/ Good till May 2018 only. Then poof, all old supported gone so XP, Vista gone.

So you updated.... (so did I) and since have tried Safe and such a clean install. Please uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. but just in case : https://support.mozilla.org/en-US/kb/profiles-where-firefox-stores-user-data save a copy first.

Reinstall with Current Release Firefox 57.0 with a Full Version Installer https://www.mozilla.org/firefox/all/

Please let us know if this solved your issue or if need further assistance.

more options

I thought I had the latest graphics driver - my mistake there was using windows's own "check for updates" telling me that there were no updates available. Going direct to AMD's site and downloading drivers directly actually seems to have solved the problem.