Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

H.264 Support openSuse KDE

  • 3 replies
  • 2 have this problem
  • 8 views
  • Last reply by cor-el

more options

Hi!

My system: openSUSE Leap 42.1, KDE Plasma 5, 64-bit system

I am trying to watch H.264 encoded videos but no success.

Config what I already tried:

media.mediasource.ignore_codecs -> True media.fragmented-mp4.use-blank-decoder -> False media.fragmented-mp4.enabled -> true

All Replies (3)

more options

The media.fragmented prefs are obsolete in Firefox 44+ and have been replaced by compacter media prefs.

  • media.fragmented-mp4.enabled -> media.mp4.enabled

Do you have this problem with all H.264 encoded videos or only with some specific videos that may use unsupported codecs?

Does YouTube work with the HTML5 media player?

Make sure you have the latest GStreamer and FFmpeg updates installed.

You can also check the graphics section in the about:support (Help > Troubleshooting Information) page for WebM (VP9) related error messages.

What does the YouTube HTML5 test page show?


Bug 1214932 - Remove "fragmented-mp4" from media prefs (44+) Bug 1234092 - Remove gstreamer support (46+)

more options

How can I delete or rename a preference in about:config?

I have GStreamer and FFmpeg updated.

The YouTube HTML5 test page show problem only with H.264 (HTML5 enabled). H.264 video does not work on this site also, the others do.

more options

You can reset a pref on the about:config page via the right-click context menu to the default value to undo/reverse changes you have made.