Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

cant do a seach in your browser.

  • 8 replies
  • 36 have this problem
  • 1 view
  • Last reply by simmo2007

more options

Your connection is not secure

The owner of www.google.com has configured their website improperly. To protect your information from being stolen, Firefox has not connected to this website.

This site uses HTTP Strict Transport Security (HSTS) to specify that Firefox only connect to it securely. As a result, it is not possible to add an exception for this certificate.

All Replies (8)

more options

Is this problem only with Google, or does it affect other HTTPS connections as well, such as this site? When you get this for pretty much all secure sites, the problem usually is one of the following:

(1) Error in your system's date, time, or time zone, which throws off certificate validity checks. Sometimes allowing computers to use an internet-based time source can introduce this problem.

(2) Firefox not being set up to work with your security software that intercepts and filters secure connections. Products with this feature include Avast, BitDefender, ESET, and Kaspersky; AVG has a Search Shield feature which can cause this error on search sites.

(3) On Windows 10, Firefox not being set up to work with the parental control software Microsoft Family Safety. (To test by turning it off, see: http://windows.microsoft.com/en-us/wi.../turn-off-microsoft-family-settings)

(4) Malware on your system intercepting secure connections.

So... which is it?

If you have any of those specific security products, that would be the first thing to check. We might be able to assist with specific next steps based on what you have if you tell us.


To gather further information, you could inspect a sample certificate to see whether that points to the culprit. If you want to try that now, here's how I suggest starting:

Load my test page at: https://jeffersonscher.com/res/jstest.php

You likely will get an error page. Expand the "I understand the risks" section and look for an Add Exception button.

Note: You don't need to complete the process of adding an exception -- I suggest not adding one until we know this isn't a malware issue -- but you can use the dialog to view the information that makes Firefox suspicious.

Click Add Exception, and the certificate exception dialog should open.

Click the View button. If View is not enabled, try the Get Certificate button first.

This should pop up the Certificate Viewer. Look at the "Issued by" section, and on the Details tab, the Certificate Hierarchy. What do you see there? I have attached a screen shot for comparison.

more options

all other sites are ok. it appears only with google, yahoo and bing. amazon etc appear ok.

more options

i just restarted the computer and its working now.

more options

Hi This problem is still happening. I will continue to use mozilla for the websites it works with. However i will have to use Microsoft edge until a easy solution is found for things like google searches. Please let me know when you have an easy download solution. Many Thanks, David

more options

Hi David, do you use AVG security software? If so, could you test with the LinkScanner Surf-Shield feature and the Online Shield feature disabled in AVG: https://support.avg.com/SupportArticleView?l=en_US&urlName=How-to-disable-individual-AVG-components

If you do not use AVG, do you use any of the other software I mentioned before?

more options

Hi I didn't understand most of the above. I use Bullgaurd. I did click your link and it looked ok to me. Thanks.

more options

There is a new issue with Bullguard that users have reported, but I don't know the best approach to working around it:

more options

Thank you very much. I can see the issue is being addressed. That's good enough for me. I wait for the final solution. Thanks again. David.