Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

FF40 with Win10 makes Helvetica bold by default

  • 6 replies
  • 5 have this problem
  • 118 views
  • Last reply by Brian

more options

I'm using Windows 10. Unlike Firefox 39, the latest version 40 has a weird way to render Helvetica. (Or is it Helvetica Neue?) What am I to do?

Attached screenshots

Chosen solution

Sorry, I made a mistake. This is the correct solution:

Set gfx.font_rendering.directwrite.enabled to true and mozilla.widget.render-mode to 6.

Read this answer in context 👍 0

All Replies (6)

more options

You can right-click and select "Inspect Element" to open the Inspector (Firefox/Tools > Web Developer) with this element selected.

You can check the font used for selected text in the Font tab in the right pane of the Inspector.

more options

cor-el said

You can right-click and select "Inspect Element" to open the Inspector (Firefox/Tools > Web Developer) with this element selected. You can check the font used for selected text in the Font tab in the right pane of the Inspector.

It appears to be Helvetica Neue. Anyway, other fonts like Mozilla's very own FF Fira Mono look much thinner and terribly rendered with FF40 as well. I can reproduce this with the respective portable versions of FF39 and FF40. The upgrade causes a significant change in how fonts are rendered.

more options

For some reason, Direct 2D was deactivated. I've seen bug reports linking this to Nvidia drivers, but I don't have that kind of hardware. So, I opened about:config and set

gfx.font_rendering.directwrite.enabled to false and mozilla.widget.render-mode to 6.

If the last entry is missing, create a new integer.

Everything's fine now.

more options

Oh, and don't forget to restart the browser! :)

more options

Chosen Solution

Sorry, I made a mistake. This is the correct solution:

Set gfx.font_rendering.directwrite.enabled to true and mozilla.widget.render-mode to 6.

more options

I had this problem with Windows 8.1. Turns out the only Helvetica Neue font I had installed was the Bold type. Apparently Firefox, unlike Chrome, chooses this variant even if the website didn't ask for it.

I just deleted the font from my system and that fixed the problem.