Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

how to disable right click menu?

  • 5 replies
  • 1 has this problem
  • 6 views
  • Last reply by cor-el

more options

I'm using a web application where it's required to right click to access a menu with different options. However I always get the Firefox right click menu on top which is very annoying and can't find a way to disable it. I contacted the software vendor and it appears they (or some other customers) never had (or reported) this problem... could you advise a way to disable it?

I'm using a web application where it's required to right click to access a menu with different options. However I always get the Firefox right click menu on top which is very annoying and can't find a way to disable it. I contacted the software vendor and it appears they (or some other customers) never had (or reported) this problem... could you advise a way to disable it?
Attached screenshots

All Replies (5)

more options

This is going to require a change in the software. You can tell them the following:

Unless you prevent the default with event.preventDefault(), the browser right-click menu will show. An example of this is http://jsfiddle.net/7xry5rbe/.

Also, all browsers do this the same way - this will happen outside of Firefox as well.

more options

First, you can press and release the Alt key to clear Firefox's context menu and reveal any menu the site has generated behind it.

Second, there is a setting to make sure Firefox's menu is always shown even if the site tries to replace it. Most users have not turned on that setting, but if you have been using Firefox for many years, back to when there were Advanced script settings available through the Options dialog, you might have done it back then. You could check here:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste contex and pause while the list is filtered

(3) If the dom.event.contextmenu.enabled preference is bolded and "user set" to false, double-click it to restore the default value of true.

more options

This is likely a problem with the dom.event.contextmenu.enabled pref that jscher2000 mentions as the third suggestion in the above post, so make sure that this pref is set to true.

Note that there are dom.disable_window* prefs to prevent websites from hiding UI items that are useful.

There are a few more dom.event.* and dom.disable* prefs that are best left to their defaults.

dom.allow_scripts_to_close_windows  [false]
dom.disable_beforeunload  [false]
dom.disable_image_src_set  [false]
dom.event.clipboardevents.enabled  [true]
dom.event.contextmenu.enabled  [true]
more options

jscher2000 said

First, you can press and release the Alt key to clear Firefox's context menu and reveal any menu the site has generated behind it. Second, there is a setting to make sure Firefox's menu is always shown even if the site tries to replace it. Most users have not turned on that setting, but if you have been using Firefox for many years, back to when there were Advanced script settings available through the Options dialog, you might have done it back then. You could check here: (1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste contex and pause while the list is filtered (3) If the dom.event.contextmenu.enabled preference is bolded and "user set" to false, double-click it to restore the default value of true.


Thanks for the info, the setting is indeed set to "false" but locked (in italic) ... I don't seem to have permission to unlock so will ask administrators,

more options

Are more prefs locked?

You can check that by clicking the Status column to sort by its content.