Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 36 very slow connecting - Says "Connecting ...." - while other browsers work

  • 8 replies
  • 4 have this problem
  • 3 views
  • Last reply by tgoecke

more options

since FF 36 users within our network have problems connecting to web sites. Time to load the entire page is in the range of Minutes. Same behavior for different users after upgrading to FF36. Creating a new profile - same behavior Using portable version - same behavior enabled / disabled: network.dns.disableIPv6 network.dns.disablePrefetch network.http.spdy.enabled.http2 network.http.spdy.enabled.http2draft - same behavior


Using managed F-Secure Client Security

No problems at all with Chrome and IE11. Very odd - any idea?

since FF 36 users within our network have problems connecting to web sites. Time to load the entire page is in the range of Minutes. Same behavior for different users after upgrading to FF36. Creating a new profile - same behavior Using portable version - same behavior enabled / disabled: network.dns.disableIPv6 network.dns.disablePrefetch network.http.spdy.enabled.http2 network.http.spdy.enabled.http2draft - same behavior Using managed F-Secure Client Security No problems at all with Chrome and IE11. Very odd - any idea?

Chosen solution

Try to toggle network.dns.get-ttl to false on the about:config page.

Read this answer in context 👍 1

All Replies (8)

more options

Try Firefox Portable ESR that is simple for end users to install and test with. Maybe even consider deploying and supporting ESR yourselves

  • Are you only having problems within your own network ?
  • I have noticed occasional reports on the forum of a more general issue e.g.
    Work around for server not found problems on FF36 /questions/1049998

Blind guess but http/2 support is new in fx36. I suggest as a test you temporarily disable that. Toggle the two prefs to false using about:config

  1. network.http.spdy.enabled.http2
  2. network.http.spdy.enabled.http2draft
more options

On re-reading your post, you have already tried those two prefs.

If you are certain the effect is real and seen in Fx36 but not Fx35.0.1 file a bug at bugzilla.

Note however some users may have suggested similar problems are seen in Fx36 but resolved if Windows SafeMode is used. If that is the case then such an issue may not be a Firefox bug.

more options

Update. This may be the fix and should be out in a few days with Fx36.0.1

more options

Chosen Solution

Try to toggle network.dns.get-ttl to false on the about:config page.

more options

> Try to toggle network.dns.get-ttl to false on the about:config page.

THANKS - that did the trick - great!

Is this a new setting in ff36? Or what has changed in relation to this? Cheers, Thomas

Modified by tgoecke

more options

John99 said

Update. This may be the fix and should be out in a few days with Fx36.0.1

Thanks John, appreciate your feedback.

more options

Note that Firefox 36.0.1 has been released, so you can update and see if it works with the pref I mentioned above set to default.

more options

cor-el said

Note that Firefox 36.0.1 has been released, so you can update and see if it works with the pref I mentioned above set to default.

Works! Thanks a lot. So bug seems to be fixed.