Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why does firefox repeatedly ask if I want to save a password when I've already clicked "Never for this site"?

  • 3 replies
  • 2 have this problem
  • 16 views
  • Last reply by paulban

more options

I like the fact that Firefox will save my passwords but I don't want it to save crucial password like banking etc. When I enter my banking site, Firefox asks "Do I want to save this password". I click "Never for this site". But next time I go to my bank website, it asks me the same question again and again.

Is there any way I can stop Firefox doing this? Incidentally, my bank site never appears in the "Exceptions" (to saved passwords) box.

I like the fact that Firefox will save my passwords but I don't want it to save crucial password like banking etc. When I enter my banking site, Firefox asks "Do I want to save this password". I click "Never for this site". But next time I go to my bank website, it asks me the same question again and again. Is there any way I can stop Firefox doing this? Incidentally, my bank site never appears in the "Exceptions" (to saved passwords) box.

Chosen solution

You can inspect and manage permissions for the domain in the currently selected tab via these steps:

  • Click the "Site Identity Button" (globe/padlock) on the location/address bar
  • Click "More Information" to open "Tools > Page Info" with the Security tab selected
  • Go to the Permissions tab (Tools > Page Info > Permissions) to check the permissions for the domain in the currently selected tab

You can inspect and manage permissions for all domains on the about:permissions page.


Make sure not to clear the Site Preferences in case you use "Clear history when Firefox closes" or otherwise clear history.

Clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, passwords, and other website specific data.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
Read this answer in context 👍 1

All Replies (3)

more options

Try this to restart the preference:

  1. Go to the bank site and click on the lock icon in the url bar and then on "More information'
  2. The window that opens will have a few options. Click on the Security tab
  3. Under passwords click on show passwords, then delete all the stored ones
  4. Refresh the page and log in
  5. When it asks you to remember the password click never for this site.

Go to options > Security > Passwords and click on Exceptions, make sure that the bank site is listed.

Also see: How to fix preferences that won't save

more options

Chosen Solution

You can inspect and manage permissions for the domain in the currently selected tab via these steps:

  • Click the "Site Identity Button" (globe/padlock) on the location/address bar
  • Click "More Information" to open "Tools > Page Info" with the Security tab selected
  • Go to the Permissions tab (Tools > Page Info > Permissions) to check the permissions for the domain in the currently selected tab

You can inspect and manage permissions for all domains on the about:permissions page.


Make sure not to clear the Site Preferences in case you use "Clear history when Firefox closes" or otherwise clear history.

Clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, passwords, and other website specific data.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

Problem solved :)

The significant part was that when closing Firefox I had it set to remove all history except passwords. I should have had it set to remove all history except passwords and site preferences.

Many thanks to those who took the trouble to reply to my query.