Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox profiles aren't very useful - all instances open with same one

  • 3 replies
  • 2 have this problem
  • 105 views
  • Last reply by James

more options

I am running Linux: LMDE Cinnamon Edition - 64 bit I am using firefox version Mozilla Firefox 31.0

I wish to have two instances of FF running. One with my standard, personal settings and a second instance that ONLY connects to Facebook and will stop data leaking between the two. I can acheive this by opening Facebook in another browser (e.g. Chrome or Opera). I checked the ProfileManager under Firefox and created a second profile called "FB". I can run firefox -p FB and it will open an instance of FF with none of my personal settings available - that's what I was hoping for. However, if I run a second instance of FF - for example from the command line as firefox -p default it loads with the same profile as the first instance I opened, not the new profile as specified in the command.

I can only select the profile if there are no prior firefox instances running under my user-id. The first instance defines which profile is used for all subsequent executions - no matter which profile I specify on the command line. Even running firefox -ProfileManager will start with the first-specified profile, not the profile manager.

Chosen solution

Hello,

If you want to run multiple instances of Firefox, you need to add a -no-remote parameter to the command.

For example:

  • firefox -P -no-remote

Please see:

Read this answer in context 👍 0

All Replies (3)

more options

Chosen Solution

Hello,

If you want to run multiple instances of Firefox, you need to add a -no-remote parameter to the command.

For example:

  • firefox -P -no-remote

Please see:

more options

Thank you very much. I did see that option in "firefox -help" but it says: Do not accept or send remote commands; implies -new-instance

which didn't mean anything to me.

regards from a satisfied user.

more options

Just make sure you do not use the -no-remote switch with the default Profile and you only need it for the second instance.

The way you were trying to do it has not worked ever since version 1.0 and earlier Releases then.

Modified by James