Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Just opened Firefox-only shows up on top 2/3 of screen(even in fullscreen) How do I enlarge it to cover all desktop?

  • 4 replies
  • 2 have this problem
  • 2 views
  • Last reply by Epicaleb

more options

When I started it this morning, it only opened on the top 2/3 of the desktop and wanted to sync firefox. My desktop picture still shows at the bottom. Since I only use this computer and nothing else, I exited. I tried going to full screen (which I don't like) but it still only uses part of the screen. How do I get it to go back to using the entire screen and still leave the bookmarks at the top?

When I started it this morning, it only opened on the top 2/3 of the desktop and wanted to sync firefox. My desktop picture still shows at the bottom. Since I only use this computer and nothing else, I exited. I tried going to full screen (which I don't like) but it still only uses part of the screen. How do I get it to go back to using the entire screen and still leave the bookmarks at the top?

All Replies (4)

more options

Hello!

Would you please post a screenshot of the problem? It would make it much easier for us to visualize the problem. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Thanks for the clarification!

more options

This screenshot shows that the bottom part of my desktop is still visible. It looks like this even if I go to fullscreen.

more options

Sometimes the file that stores window dimensions and toolbar customizations becomes corrupted. I'm not sure whether that is the issue here, but in case that is the problem, you can rename the file and see whether that helps. This also resets some toolbar customizations.

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • Help menu > Troubleshooting Information

In the first table on the page, click the "Show Folder" button

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • File menu > Exit

Pause while Firefox finishes its cleanup, then rename localstore.rdf to something like localstore.old

Start Firefox back up again. Any improvement in how maximizing the window works?

Modified by jscher2000 - Support Volunteer

more options

Hummm...this is a very strange problem indeed. Have you tried restarting your PC? Another idea would be to start Firefox in Safe Mode.

If the problem goes away in Safe Mode but remains in a normal Firefox run, one of your add-ons is most likely causing the problem and we can go from there.

Another option would be to reset Firefox. It retains your bookmarks, open tabs, etc. and restores everything else to default.

I'm sorry I don't have a straight-out answer for you; please post back to let us know how things worked out. Also, other Mozilla Support contributors may be able to chime in with better suggestions, so check back!