Търсене в помощните статии

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox on Shaw Cable Internet cannot connect to google services such as gmail and google search.

  • 3 отговора
  • 10 имат този проблем
  • 2 изгледи
  • Последен отговор от jscher2000

more options

Called two associates and tried on two different Shaw connections at two different locations. No one can connect to Google searches on Shaw Cable internet in the Surrey, BC area using Firefox. It works with internet explorer and chrome.

Is Google doing this on purpose to get more chrome users?



Receiving following error:

Secure Connection Failed

An error occurred during a connection to www.google.ca. SSL received a record that exceeded the maximum permissible length. (Error code: ssl_error_rx_record_too_long)

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem. Alternatively, use the command found in the help menu to report this broken site.

Всички отговори (3)

more options

Hello,

Thank you for contacting us about the ssl_error_rx_record_too_long error. This issue is because of you being a Shaw customer and living in British Columbia. Shaw is aware of the issue and is working on a fix.

Thank you! Please report back to us to let us know when the issue is fixed.

See also: https://support.mozilla.org/en-US/questions/976504

more options

Shaw told me to go to about:config and change security.tls.version to max 0

works now.

more options

Hi GaryGS, that change limits Firefox to using the SSLv3 protocol, when normally Firefox would upgrade to TLSv1 if the site supports it. I recommend trying to switch it back tomorrow or the next day for stronger secure connections once Shaw's issue is resolved.