Търсене в помощните статии

Избягвайте измамите при поддръжката. Никога няма да ви помолим да се обадите или изпратите SMS на телефонен номер или да споделите лична информация. Моля, докладвайте подозрителна активност на "Докладване за злоупотреба".

Learn More

How to edit the selectable languages for spell checking?

  • 4 отговора
  • 2 имат този проблем
  • 5 изгледи
  • Последен отговор от NatsuPower

more options

Hallo Mozzila Community

After using Firefox nightly 23 on Chakra Linux via bundle and I think it messed up my settings of the spell checker via Firefox sync.

The Problem pop up on openSUSE and Chakra Linux but not In Kubuntu 12.04(it has separate language packs). I want to have German and English GB and maybe Bosnian or Croatian spell checker but I can not select it via right click -languages. Now I have on both Chakra Linux and openSUSE 12.3 Firefox 20 by default maybe 30 languages installed but I can not select the language I want.

For example on Chakra Linux Firefox 20 I have only German variants selectable,German Luxenbourg,German Belgium ... and so and I can not select other language via add-on or about:config spellchecker.dictionary; it stay alwas on a German variant so I need to edit the right click language selector to bring it to work.

2.Example on openSUSE can not select German and En_GB but I can select a bunch of other languages I do not need in the right click languages selctor.

Both are Firefox 20 with openSUSE KDE modifications and have all available spell dictionary installed.

So how can I edit the list of selectable languages on the right click-languages?

Променено на от NatsuPower

Избрано решение

Ok it is now solved.

In Chakra the English hunspell was missing and on openSUSE made a vendor change to Mozilla and now it works all fine.

sorry to boreder the comminty

Прочетете този отговор в контекста 👍 0

Всички отговори (4)

more options

There is a difference between language packs that affect the Firefox user interface and spell check dictionaries.

At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • Open the "Add Dictionaries" link to install a dictionary if you do not have one.
  • Make sure that [X] "Check Spelling" in the right-click context menu is check-marked.

You can look here for dictionaries:

more options

Sorry but You can see I have all language packs and dictionaries installed for maybe 30 languages but the problem is i can not select them.

more options

Ok now I posted to the Chakra Linux forum http://chakra-project.org/bbs/viewtopic.php?id=10303

but the problem is not yet solved so please help

I have 98 available languages installed I guess on Chakra Linux and openSUSE.

How to select an other language if it is not in the right click menu and it can not be set via about:config?

Променено на от NatsuPower

more options

Избрано решение

Ok it is now solved.

In Chakra the English hunspell was missing and on openSUSE made a vendor change to Mozilla and now it works all fine.

sorry to boreder the comminty

Променено на от NatsuPower