Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When i open Firefox the cursor focuses on the address-bar instead of being on the search-bar on the google webpage.

  • 12 отговора
  • 12 имат този проблем
  • 3871 изгледи
  • Последен отговор от Pink_Mochi

more options

The title is summing it up pretty much.

Before the cursor "switched" to the location/URL bar it was always on the Google (webpage) search-bar. I'm not talking about the Google search-bar right next to the location/URL bar.

Again,..

1) i open Firefox 2) the window pops open 3) the cursor is on the location/URL bar. 4) i'm getting frustrated

additionally

  • ) when i open a new tab, the cursor is on the search bar from the google webpage.


i would be very thankful, if someone can help me out.

ps. i already have read some articles about "new tab, wrong cursor focusing" but that is not my problem.

All Replies (12)

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.
more options

ok, i restarted it on Safe Mode with the Default Theme. and now the cursor is on the search-bar from the bookmarks.

  • by pressing Ctrl+B the bookmark pops on the left side (that's for me).
more options

That's normal for the cursor to be in the Bookmarks Sidebar Search field when the Sidebar is opened using {Ctrl + B}.

Is it in URL Bar before you open the Bookmarks Sidebar?

more options

Google uses a script to move the cursor to the search box. I notice you have the NoScript extension installed. Presumably you have allowed google.at, but you could double-check that by clicking NoScript's "S" button on the Add-on bar.

more options

@ the-edmeister:

well, when i restarted on Safe Mode the Sidebar was already popped open. Therefore i cant tell you, if its on the URL Bar before the Sidebar.

@ jscher2000:

yes, i have the NoScript extension installed and "Yes" i have allowed Google.at I checked it and tried with not allowing it. It didnt changed anything either way.


Ps. Firefox updated itself to 17 and that i didnt noticed i installed Firefox 4.0 due to TabMix Plus.

but out of curiosity i found out that i now have Firefox 17. TabMix Plus is now (finally) updated to Firefox 17.

and "Yes" on Firefox 4.0 the cursor was immediately on the Google Webpage Searchbar. and "No" i didnt changed anything on TabMix Plus recently.

I don't know, if this is of any importance. I just thought that it might be worth to mention.
more options

Does this occur with all new windows? For example, if you press Ctrl+n is the cursor in the address bar or in the Google page's search box?

If it only occurs at startup, I wonder whether there is some kind of timing problem where Google's script runs too early (or something Firefox or an add-on is doing is running later than it should).

more options

@ jscher2000:

Alas, that's a positive. It happens on all new opened windows.

Strange occurrence, ain't that right?

more options

Okay, well, consistency actually is better than inconsistency. :-)

When the new window opens, if you use reload (button at the end of the address area or Ctrl+r) does the Google script kick in and move the cursor to the search box?

more options

@ jscher2000:

Alas, no. It still stays on the URL bar.

more options

I'm running out of ideas. The default behavior for a new window (but not a new tab) is for the focus to be on the page. Moving the cursor to the address bar would require the intervention of as add-on or perhaps some external software that monitors the creation of new windows. Nothing on your list leaps out at me, but your report on the Safe Mode behavior is unusual: the cursor shouldn't move to the Bookmarks Sidebar when it is opened by default, only when you open it yourself. This points more toward some external cause for the behavior.

If the cause cannot be found and defeated, you probably could create a Greasemonkey userscript to move the focus.

more options

I stumbled across an older thread on the Google support forums that could be relevant. One suggested workaround was to switch from Instant prediction results to standard results, and the other was to disable autocomplete. Not sure whether either of those make sense for you.

Why isn't my cursor automatically in the search box anymore??? - Google Groups

more options

unfortunately.. the suggested answer from [ mbaglobaltravel ] didnt help a bit.

BUT.. i gave the suggestion of [poochiewoochie ] a try and it worked flawlessly.

it could be something about "google.at" that ticks my cursor off.

thank you for your help [ jscher2000 ]