Търсене в помощните статии

Избягвайте измамите при поддръжката. Никога няма да ви помолим да се обадите или изпратите SMS на телефонен номер или да споделите лична информация. Моля, докладвайте подозрителна активност на "Докладване за злоупотреба".

Learn More

Some pages of internet banking do not show on Firefox

  • 4 отговора
  • 0 имат този проблем
  • 21 изгледи
  • Последен отговор от sdrindani

more options

Some pages in the new internet banking site of my bank do not load while using Firefox, while they show on other browsers, including one on an android phone. For example, I was told by the customer help from the bank that if I click on my account name after login to internet banking, I should see a page with a button showing "Tax", and on that page I can click on "Download TDS" to download a tax deduction file. When I try to do this, a page showing "Tax" opens, but the page is otherwise blank. Clicking on "Tax" does not produce any result. I can carry out the "Download TDS" transaction on other browsers.

Should this be seen as a drawback of Firefox, or there is something else I can try, apart from using another browser?

Some pages in the new internet banking site of my bank do not load while using Firefox, while they show on other browsers, including one on an android phone. For example, I was told by the customer help from the bank that if I click on my account name after login to internet banking, I should see a page with a button showing "Tax", and on that page I can click on "Download TDS" to download a tax deduction file. When I try to do this, a page showing "Tax" opens, but the page is otherwise blank. Clicking on "Tax" does not produce any result. I can carry out the "Download TDS" transaction on other browsers. Should this be seen as a drawback of Firefox, or there is something else I can try, apart from using another browser?

Всички отговори (4)

more options

Hi sdrindani,

Thank you for reaching out to the Firefox Support Forum. I understand that you are experiencing issues with some pages not loading correctly in the new internet banking site of your bank when using Firefox, while they work fine in other browsers.

First, let's make sure that this issue is not specific to your Firefox installation. Please try the following troubleshooting steps:

Clear your Firefox cache: Go to the Firefox menu, select "Preferences" or "Options," then navigate to the "Privacy & Security" tab. Under the "Cookies and Site Data" section, click on the "Clear Data" button and make sure to check the box next to "Cached Web Content." Restart Firefox and try accessing the problematic pages again.

Disable Firefox extensions: Some extensions can interfere with webpage loading. Try disabling your extensions temporarily and see if the issue persists. You can do this by going to the Firefox menu, selecting "Add-ons" or "Extensions," and disabling all installed extensions. Restart Firefox and check if the pages load correctly.

Create a new Firefox profile: A corrupted profile can sometimes cause issues. You can create a new profile and see if the problem persists. Follow the instructions in this Mozilla Support article to create a new profile: [link to the support article].

If the issue still persists after trying the above steps, it would be helpful to provide additional information. Please let us know the specific version of Firefox you are using, as well as the URL of the problematic internet banking site. Also, try accessing the browser console (press Ctrl+Shift+J) while loading the problematic page and see if there are any error messages or warnings displayed.

Other community members or Mozilla volunteers may have additional suggestions to help resolve this issue. Thank you for your cooperation, and we'll do our best to assist you further.

Best regards, Firefox Support Forum Contributor

more options

This is a guess, but several banks use multiple servers for their content. You may notice the address changing in the address bar as you move around their site, or this may be transparent because the secondary server's content is embedded (in a frame in the page).

Firefox recently rolled out "Total Cookie Protection" to more users. This limits how sites can use "third party" or "cross-site" cookies, meaning cookies from different websites than the one you see in the address bar. For sites that use different servers for different services, you might not be trusted as having logged in as you move around the site.

You can make exceptions to this feature when needed (for each server that you visit as part of the process of using this company's services). More info in the following articles:

Any difference?

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console for relevant-looking messages about blocked content.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window
more options

Thank you, suram080, jscher2000 and cor-el, for your prompt responses with suggestions.

I could not try out the suggested solutions very quickly.

So far, I tried

1. Clearing firefox caches, and then restarting firefox. This did not help.

2. disabling adblockerplus and then restarting firefox. This did not help.

3. disabling enhanced tracker protection for the bank site. This did not help. I should mention that the main URL of the internet banking site did not change in going from one page to another.

But wait! That is not all! The next day, I tried the bank site again. I noticed that while I had re-enabled adblockerplus, I still had the shield symbol disabled in the URL window -- so the enhanced tracker protection was still off. Surprisingly, the "Tax" page of the bank site , about which I complained, now showed up!

What is more, now it works with adblocker plus enabled, as also enhanced tracker protection enabled. There is a slight chance that the bank has changed their netbanking app, just when I was trying out these suggestions! But this is too much of a coincidence. Somehow, trying out one or more suggestions seems to have helped after the computer slept over it for a night! (I wonder if it was rebooting which helped).

Thank you all, anyway. If I still run into a problem, I still have more suggestions I can carry out.