Търсене в помощните статии

Избягвайте измамите при поддръжката. Никога няма да ви помолим да се обадите или изпратите SMS на телефонен номер или да споделите лична информация. Моля, докладвайте подозрителна активност на "Докладване за злоупотреба".

Learn More

embedded video won't show up

  • 4 отговора
  • 2 имат този проблем
  • 30 изгледи
  • Последен отговор от cor-el

more options

Just as detailed in Support Question 1173275, an embedded YouTube video doesn't show up in Firefox. The area of the web page (bringatrailer.com) is blank. In Chrome, the preview picture appears and the link works. The video plays for me on the YouTube website. I would have asked this in the existing question, but the registration process sent me here.

thank you- -Dan Farmer

Всички отговори (4)

more options

Hi Dan, a new question is good because you can share your Firefox configuration with us -- thank you for that.

The video (https://bringatrailer.com/listing/1967-chevrolet-nova/) appears normally for me in Firefox 57 on Windows. Have you tried "the usual":

If a site is generally known to work in Firefox, these are general suggestions to try when it stops working normally:

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button

In the dialog that opens, the current site should be pre-filled in the search box at the top of the dialog so you can remove that site's cookies individually.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of Shift.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Променено на от jscher2000

more options

If you visit the site in a private browsing window, check for a "shield" icon toward the left end of the address bar. While I don't think YouTube embeds are normally blocked by the Tracking Protection feature, that would indicate that something is being blocked. More info in this article: What happened to Tracking Protection?.

more options

Thank you. Now it works. Specifically: 1) I cleared the cache and refreshed the page. No improvement. 2) I removed the site's cookies and refreshed the page. No improvement. 3) I Restarted Firefox in safe Mode. Now it works! 4) I closed and restarted Firefox normally. It still works!

thank you very much- -df

more options

Note that usually the first to try is a reload and bypass the cache to refresh possibly corrupted data that is cached.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)