Търсене в помощните статии

Избягвайте измамите при поддръжката. Никога няма да ви помолим да се обадите или изпратите SMS на телефонен номер или да споделите лична информация. Моля, докладвайте подозрителна активност на "Докладване за злоупотреба".

Learn More

Prevent specific website from storing login name in drop-down list

  • 4 отговора
  • 4 имат този проблем
  • 1 изглед
  • Последен отговор от Cronk

more options

I have a website that I log into frequently. Their homepage has a login field. If I double-click that field, it shows me various login names to auto-populate with. I would like to prevent Firefox (or whatever) from remembering these login names, as a security measure due to my personal paranoia.

I'm using Firefox 49.0.2.

  • I have added this website to my Cookies block list. New Cookies are not showing up when I log in.
  • I do NOT have any stored logins for this site (they were removed and new ones are not showing up when I enter a name).
  • Firefox is NOT showing me the 'Do you want to remember this?' dialog.
  • I have removed any stored UNs from this field's auto-complete list by using the 'shift+Delete' keys to highlight and delete the entries that show up when I double click the field.
  • The list that shows up when I double click is NOT specific to this site...or rather, the entries in the list appear to show up from almost any site that I have logged into. E.g. I cleared all the entries for this site I am concerned about; I then came over to the Mozilla Support forum and tried logging in; I had to try a few times; now all of those names that I used on the Mozilla login field are showing up in the list for the original website.
  • Curiously...if I hit 'return' after typing my name (causing the website to go to the next page), the name I typed into the field appears to NOT be remembered. However, if I click on the 'login' button next to the field after typing a login name, the name appears to get remembered.
  • Even if I turn off 'Remember logins...' in Firefox, the UN I enter into this field gets remembered.

A screen shot is included of the entry field and the drop-down list of names (which I have cleared many times).

I have a website that I log into frequently. Their homepage has a login field. If I double-click that field, it shows me various login names to auto-populate with. I would like to prevent Firefox (or whatever) from remembering these login names, as a security measure due to my personal paranoia. I'm using Firefox 49.0.2. * I have added this website to my Cookies block list. New Cookies are not showing up when I log in. * I do NOT have any stored logins for this site (they were removed and new ones are not showing up when I enter a name). * Firefox is NOT showing me the 'Do you want to remember this?' dialog. * I have removed any stored UNs from this field's auto-complete list by using the 'shift+Delete' keys to highlight and delete the entries that show up when I double click the field. * The list that shows up when I double click is NOT specific to this site...or rather, the entries in the list appear to show up from almost any site that I have logged into. E.g. I cleared all the entries for this site I am concerned about; I then came over to the Mozilla Support forum and tried logging in; I had to try a few times; now all of those names that I used on the Mozilla login field are showing up in the list for the original website. * Curiously...if I hit 'return' after typing my name (causing the website to go to the next page), the name I typed into the field appears to NOT be remembered. However, if I click on the 'login' button next to the field after typing a login name, the name appears to get remembered. * Even if I turn off 'Remember logins...' in Firefox, the UN I enter into this field gets remembered. A screen shot is included of the entry field and the drop-down list of names (which I have cleared many times).
Прикачени екранни снимки

Избрано решение

I disable Firefox's form history, so I don't know whether it is site-specific (like saved logins) or could possible appear on every site with a similarly named field, which seems a bit odd.

If you turn off Firefox's form history feature, does the unwanted suggestion stop appearing? You can do that on the Preferences page, Privacy panel:

"3-bar" menu button (or Firefox menu) > Preferences

In the left column, click Privacy. On the right side, if you do not see "Firefox will: Use custom settings for history" go ahead and make that selection.

Then you can uncheck the box for "Remember search and form history".

When you return to the site and reload the page, do the suggestions disappear?

Прочетете този отговор в контекста 👍 1

Всички отговори (4)

more options

Избрано решение

I disable Firefox's form history, so I don't know whether it is site-specific (like saved logins) or could possible appear on every site with a similarly named field, which seems a bit odd.

If you turn off Firefox's form history feature, does the unwanted suggestion stop appearing? You can do that on the Preferences page, Privacy panel:

"3-bar" menu button (or Firefox menu) > Preferences

In the left column, click Privacy. On the right side, if you do not see "Firefox will: Use custom settings for history" go ahead and make that selection.

Then you can uncheck the box for "Remember search and form history".

When you return to the site and reload the page, do the suggestions disappear?

more options

Jscher2000...that appears to be the issue. When I deselected the 'Remember Search and Form history' option in the FF preferences, the login name stopped showing up. All of them did...it doesn't even show you any options when you double click the field. Which is mostly what I wanted...but it would be nice if it were site specific. (There are certain sites that I don't mind having the input-field information stored.)

But where's the line between 'form' and 'login'? I'm guessing that you are right that it is due to the IDname given to the HTML form field. But FF has to be making some distinction somewhere that certain things are 'logins' and others are 'forms'...so why doesn't it correctly register this site as a 'login'?

This particular page uses this definition: <input class="form-control" id="username" name="username" placeholder="Username" type="text">

more options

Hi Cronk, when you enable saving of logins, Firefox looks for username+password pairs. When that is disabled, I guess a username field is just another field.

One way I think sites can block form history is by marking the control for no autocomplete:

<input class="form-control" id="username" name="username" placeholder="Username" type="text" autocomplete="off">

To have that happen automatically when you load the page, you would need an add-on, either some general purpose tool, or a "user script" you apply to the page using the Greasemonkey extension.

Userscripts can be coded to run on all sites or target only a particular domain, and run automatically when the page loads. Either way, you probably would have the script scan the page for any field with name="username" (for example) and add autocomplete="off" to it. Some sites include their login form in the initial HTML they send, which is the easiest to script for, while others generate the form using a script after the page loads, which requires a more complicated script.

I might be able to create a script this weekend if you don't find anything ready-made.

more options

Thanks for the advice and offer of a script; I think that all sounds a bit more involved than I was planning on getting with this. Even my paranoia has limits.  :)

I would think that Firefox would treat anything with 'username' as the field ID as a 'Login' and store/control it under that system. That would solve these issues from my point of view - allow me to prevent this website from remembering my login, but allow me to allow other pages to remember it. I would say that it's a rather common paradigm anymore for more secure sites to split up the UN field from the PW field.