Търсене в помощните статии

Избягвайте измамите при поддръжката. Никога няма да ви помолим да се обадите или изпратите SMS на телефонен номер или да споделите лична информация. Моля, докладвайте подозрителна активност на "Докладване за злоупотреба".

Learn More

Where is the scrollbar, how can I force one even when source wants it to not be there?

  • 2 отговора
  • 4 имат този проблем
  • 1790 изгледи
  • Последен отговор от moby1

more options

As an end user (not developer) how do I force my web-browser to have a (vertical) scrollbar?

I am looking at a web page designed for a full height screen. When using a desktop with external large monitor not a problem. However when using a small laptop screen (e.g.: ThinkPad with small height screen) the bottom of the web page gets cut off. If I make the page smaller (about 67%) zoom - then the page fits but it it not possible to identify the info I seek as font is now too small and overlapping.

In general as an end user I want to force my web-browser to have a scrollbar no matter what the source says - my PC my choice.

Избрано решение

There are two possible reasons for this:

(1) In popup windows, sites can specify which bars are available and which are not. There is an optional setting to prevent sites from hiding scrollbars.

(2) In all pages, sites can insert a style rule which prevents scrollbars. This is harder to overcome, probably requiring an add-on.

Pop-up windows

To change this setting:

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(B) In the search box above the list, type or paste feat and pause while the list is filtered

(C) Double-click the dom.disable_window_open_feature.scrollbars to switch it from false to true, meaning the site is disabled from controlling whether popup windows are opened with or without scrollbars. Firefox will simply follow the style rules for the content.

overflow: hidden

To prevent scrollbars, sites can specify that instead of triggering a scroll bar, "overflow" is hidden (meaning truncated, not shown). Zooming out will bring the hidden content into view, but often this makes the content too small.

If you only need a fix for this from time to time, you could use a bookmarklet, which is a script that you save as a bookmark to a convenient location, such as your bookmarks toolbar or bookmarks menu. Most sites still allow bookmarklets to modify their pages, only a few block them (using CSP, more on that if needed).

(A) Select and copy the following bookmarklet script:

javascript:var r="html,body{overflow:auto !important;}"; var s=document.createElement("style"); s.type="text/css"; s.appendChild(document.createTextNode(r)); document.body.appendChild(s); void 0;

(B) Right-click a place on the Bookmarks Toolbar or Bookmarks Menu where you would like to create the new bookmark and choose New Bookmark

(C) In the small dialog that opens, right-click in the Location and Paste (or click in the Location and Ctrl+v) to enter the script there

(D) Name the bookmark something like Scrollable or whatever you like and click the Add button

Then, to test, open the problem page and click the button. Does it work?

Прочетете този отговор в контекста 👍 2

Всички отговори (2)

more options

Избрано решение

There are two possible reasons for this:

(1) In popup windows, sites can specify which bars are available and which are not. There is an optional setting to prevent sites from hiding scrollbars.

(2) In all pages, sites can insert a style rule which prevents scrollbars. This is harder to overcome, probably requiring an add-on.

Pop-up windows

To change this setting:

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(B) In the search box above the list, type or paste feat and pause while the list is filtered

(C) Double-click the dom.disable_window_open_feature.scrollbars to switch it from false to true, meaning the site is disabled from controlling whether popup windows are opened with or without scrollbars. Firefox will simply follow the style rules for the content.

overflow: hidden

To prevent scrollbars, sites can specify that instead of triggering a scroll bar, "overflow" is hidden (meaning truncated, not shown). Zooming out will bring the hidden content into view, but often this makes the content too small.

If you only need a fix for this from time to time, you could use a bookmarklet, which is a script that you save as a bookmark to a convenient location, such as your bookmarks toolbar or bookmarks menu. Most sites still allow bookmarklets to modify their pages, only a few block them (using CSP, more on that if needed).

(A) Select and copy the following bookmarklet script:

javascript:var r="html,body{overflow:auto !important;}"; var s=document.createElement("style"); s.type="text/css"; s.appendChild(document.createTextNode(r)); document.body.appendChild(s); void 0;

(B) Right-click a place on the Bookmarks Toolbar or Bookmarks Menu where you would like to create the new bookmark and choose New Bookmark

(C) In the small dialog that opens, right-click in the Location and Paste (or click in the Location and Ctrl+v) to enter the script there

(D) Name the bookmark something like Scrollable or whatever you like and click the Add button

Then, to test, open the problem page and click the button. Does it work?

more options

Reason (1) popup window /fix already implemented for online banking etc sites.

Reason (2) and solution 'bookmarklet script' did the trick for my specific problem. Works great in Firefox, and Chrome too.