Търсене в помощните статии

Избягвайте измамите при поддръжката. Никога няма да ви помолим да се обадите или изпратите SMS на телефонен номер или да споделите лична информация. Моля, докладвайте подозрителна активност на "Докладване за злоупотреба".

Learn More

Firefox doesn't update changed webpage

  • 6 отговора
  • 2 имат този проблем
  • 35 изгледи
  • Последен отговор от paziu

more options

I have a website and I made changes in my website but the changes doesn't appear in the web page by using firefox. my firefox is set to never remember history and I have cleared all type of stored data but the changes doesn't appear in my website. when i restart the computer and visit my website it does update my page.

I tested my website in other browser and they display updated version of my web page but firexfox is still showing non updated version of my webpage.

before i was unable to save preferences of my firefox after resetting the firefox it does saves settings but firefox doesn't update changes in my web page. i am very confused now.

All my addons are disabled, i am using windows 7 64 bit.

any solution please?

Всички отговори (6)

more options

I have seen some odd behavior in some browsers including FF when it comes to problems with re-fresh/caching. What I do is close the tab and restart the browser... to make sure. If you would like to make sure the caching is disabled from the web server/HTML, use the following in the header of your page(s):

<meta http-equiv="cache-control" content="max-age=0" /> <meta http-equiv="cache-control" content="no-cache" /> <meta http-equiv="expires" content="0" /> <meta http-equiv="expires" content="Tue, 01 Jan 1980 1:00:00 GMT" /> <meta http-equiv="pragma" content="no-cache" />

source: http://stackoverflow.com/questions/1341089/using-meta-tags-to-turn-off-caching-in-all-browsers

more options

init said

I have seen some odd behavior in some browsers including FF when it comes to problems with re-fresh/caching. What I do is close the tab and restart the browser... to make sure. If you would like to make sure the caching is disabled from the web server/HTML, use the following in the header of your page(s): <meta http-equiv="cache-control" content="max-age=0" /> <meta http-equiv="cache-control" content="no-cache" /> <meta http-equiv="expires" content="0" /> <meta http-equiv="expires" content="Tue, 01 Jan 1980 1:00:00 GMT" /> <meta http-equiv="pragma" content="no-cache" /> source: http://stackoverflow.com/questions/1341089/using-meta-tags-to-turn-off-caching-in-all-browsers

many thanks sir for your answer but i tried the same web page in other browser it works fine but the problem is only in firefox settings etc. would you help me to repair this firefox issue?

more options

did you try this - verify the settings:

in the URL type: about:config

locate the following configuration variables and compare/change the values:

browser.cache.disk.enable false browser.cache.disk.capacity 0 browser.cache.disk.smart_size.enabled false

more options

init said

did you try this - verify the settings: in the URL type: about:config locate the following configuration variables and compare/change the values: browser.cache.disk.enable false browser.cache.disk.capacity 0 browser.cache.disk.smart_size.enabled false

I just tried above mentioned but it didn't worked.

more options

verify also that your browser does not connect using a "proxy" - a caching proxy will develop such behavior - it is often changed by 3rd party applications, and malware/spyware, or simply by the user.

options/advanced/network/connection

more options

also, after you exit from Firefox, go to the task manager and make sure there is no other instance of FF running.... end the task if exists...