X
Tap here to go to the mobile version of the site.

Support Forum

Enabled hardware acceleration in version 33+ causing everything to render in solid black on Intel HD3000 (on both 2 years old and latest drivers).

Posted

Hello, I'm experiencing troubles with Firefox versions 33+. Enabling hardware acceleration makes everything render in solid black, even on clean profile, even the "Choose profile" and "Firefox already running" dialogs. Problem started when developers started to work on MSE.

Also the font rendering is doing wild things - some characters like 'l' (small L), 'i' and '-' at certain font sizes are not rendered at all and some characters like '=' are rendered partially like '-'. Of course with hardware acceleration disabled. This is pretty annoying, because it appears in places I use a lot like address bar and youtube HTML5 player, leading to those render failures: 'Exit full screen' renders as 'Ex t fu screen' or 'https://www.google.com/search?q=mozilla+firefox&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:unofficial&client=firefox-nightly&channel=fflb' renders as 'https://www.google.com/search?q-mozilla+firefox&ie-utf 8&oe=utf 8&aq-t&rls-org.mozilla:en-US:unofficial&client-firefox nightly&channel-fflb'

Is there anything I can do about it? I've tried to update graphic drivers through my laptop manufacturer official sources and through intel's website, but neither did help.

Thanks.

Hello, I'm experiencing troubles with Firefox versions 33+. Enabling hardware acceleration makes everything render in solid black, even on clean profile, even the "Choose profile" and "Firefox already running" dialogs. Problem started when developers started to work on MSE. Also the font rendering is doing wild things - some characters like 'l' (small L), 'i' and '-' at certain font sizes are not rendered at all and some characters like '=' are rendered partially like '-'. Of course with hardware acceleration disabled. This is pretty annoying, because it appears in places I use a lot like address bar and youtube HTML5 player, leading to those render failures: 'Exit full screen' renders as 'Ex t fu screen' or 'https://www.google.com/search?q=mozilla+firefox&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:unofficial&client=firefox-nightly&channel=fflb' renders as 'https://www.google.com/search?q-mozilla+firefox&ie-utf 8&oe=utf 8&aq-t&rls-org.mozilla:en-US:unofficial&client-firefox nightly&channel-fflb' Is there anything I can do about it? I've tried to update graphic drivers through my laptop manufacturer official sources and through intel's website, but neither did help. Thanks.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 14.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
12013 solutions 111604 answers

Do you mean that you get corrupted characters when Firefox hardware acceleration is disabled?

Does it help if you disable MSE as a test in case you have enabled it (the default still seems to be false)?

  • media.mediasource.enabled = false
Do you mean that you get corrupted characters when Firefox hardware acceleration is disabled? Does it help if you disable MSE as a test in case you have enabled it (the default still seems to be false)? *media.mediasource.enabled = false

Question owner

I've tried setting mediasource, direct2d and directwrite options, the last two helped with the rendering bug, but the fonts looked so ugly I've switched back to bugged version. Everything with clean profile and hardware acceleration disabled.

But what bothers me more is the fact that hardware acceleration (switched on by default) is causing firefox to appear as a solid black area (buttons work, I'm able to close or minimize the window). I will test it on another laptop with 2nd generation Intel Core HD graphics to see if it's only something odd with my system or if it's actually a bug.

I've tried setting mediasource, direct2d and directwrite options, the last two helped with the rendering bug, but the fonts looked so ugly I've switched back to bugged version. Everything with clean profile and hardware acceleration disabled. But what bothers me more is the fact that hardware acceleration (switched on by default) is causing firefox to appear as a solid black area (buttons work, I'm able to close or minimize the window). I will test it on another laptop with 2nd generation Intel Core HD graphics to see if it's only something odd with my system or if it's actually a bug.
hooligan131 0 solutions 3 answers

Helpful Reply

I had the same thing with a nvidia gpu (660GTX) and ff nightly 33 .... every thing had big black pulsing borders like the css animations code had gone mental and the whole screen was flickery .. and all the text was clipping when scrolling creating trails .. I went into the gpu settings disabled acceleration and it worked perfectly after that so I can confirm that 3D accellerations has issue in 33.

I had the same thing with a nvidia gpu (660GTX) and ff nightly 33 .... every thing had big black pulsing borders like the css animations code had gone mental and the whole screen was flickery .. and all the text was clipping when scrolling creating trails .. I went into the gpu settings disabled acceleration and it worked perfectly after that so I can confirm that 3D accellerations has issue in 33.

Question owner

This problem disappeared approximately 4 days ago (can't tell for sure since I've been very busy lately and I've lost track of time) with regular Nightly update (don't know what was causing it and don't know what solved it).

This problem disappeared approximately 4 days ago (can't tell for sure since I've been very busy lately and I've lost track of time) with regular Nightly update (don't know what was causing it and don't know what solved it).