Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox telling users that Java is out of date

  • 4 cavab
  • 3 have this problem
  • 7 views
  • Last reply by James

more options

Currently, the latest Java version out for WIndows PC, is Java7 U51. Java8 has been released in Beta version. When you do a check in Firefox to check if your plugins are up do date, Firefow tells you that Java is out of date. It wants you to upgrade to Java8. Its been this way from the day Java8 was released in Bate version That shouldn't be. As long as Java8 is only Beta, the lates veriosn that can be referenced is Java7U51. Please fix.

Chosen solution

Yes, sorry, this is a known problem and has been posted in the bug tracking system where different approaches are under discussion.

Due to a change in Firefox 29, a completely different system is being developed for plugin checking, and based on what I read yesterday, that might be taking priority over various lingering problems with the current plugin checker.

Read this answer in context 👍 2

All Replies (4)

more options

Seçilmiş Həll

Yes, sorry, this is a known problem and has been posted in the bug tracking system where different approaches are under discussion.

Due to a change in Firefox 29, a completely different system is being developed for plugin checking, and based on what I read yesterday, that might be taking priority over various lingering problems with the current plugin checker.

more options

Version 29? Version 28 hasn't been out for very long and here were talking about a whole new version. Cool.

more options

Thanks jscher2000

Modified by user1072808

more options

BenjaminLindner, Firefox 29.0, 30.0 and 31.0 are currently in different channels of development. Right now Fx 29.0 is on Beta channel at 29.0b3.